aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-DOMHandler
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-05 00:39:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-05 00:39:35 +0000
commit163c3fea0bceff1828e060ba86f07a42bf139f55 (patch)
tree03e553ffc20af12e6314fc59f441757dfae96cf3 /textproc/p5-XML-DOMHandler
parenta18deed4a235dc6e8d2ef38802949847b58dc245 (diff)
downloadports-163c3fea0bceff1828e060ba86f07a42bf139f55.tar.gz
ports-163c3fea0bceff1828e060ba86f07a42bf139f55.zip
This module creates a layer on top of DOM that allows you to program
in a "push" style rather than "pull". Once the document has been parsed and you have a DOM object, you can call on the DOMHandler's traverse() method to apply a set of call-back routines to all the nodes in a tree. WWW: http://search.cpan.org/dist/XML-DOMHandler-1.0/ PR: 137424 Submitted by: Stefan Pauly <stefan@fh-mainz.de>
Notes
Notes: svn path=/head/; revision=238923
Diffstat (limited to 'textproc/p5-XML-DOMHandler')
-rw-r--r--textproc/p5-XML-DOMHandler/Makefile21
-rw-r--r--textproc/p5-XML-DOMHandler/distinfo3
-rw-r--r--textproc/p5-XML-DOMHandler/pkg-descr6
-rw-r--r--textproc/p5-XML-DOMHandler/pkg-plist5
4 files changed, 35 insertions, 0 deletions
diff --git a/textproc/p5-XML-DOMHandler/Makefile b/textproc/p5-XML-DOMHandler/Makefile
new file mode 100644
index 000000000000..8b6951111aa5
--- /dev/null
+++ b/textproc/p5-XML-DOMHandler/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: XML-DOMHandler
+# Date created: 4 August 2009
+# Whom: Stefan Pauly <stefan@fh-mainz.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-DOMHandler
+PORTVERSION= 1.0
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= stefan@fh-mainz.de
+COMMENT= A call-back interface to DOM
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::DOMHandler.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-DOMHandler/distinfo b/textproc/p5-XML-DOMHandler/distinfo
new file mode 100644
index 000000000000..529934935cb6
--- /dev/null
+++ b/textproc/p5-XML-DOMHandler/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-DOMHandler-1.0.tar.gz) = 6dd4dcfed53eb23976c82d097225b430
+SHA256 (XML-DOMHandler-1.0.tar.gz) = 7c7041533ec8a401dcc55b52dc7b28c56d971d941ee3698127c67f2f0242812a
+SIZE (XML-DOMHandler-1.0.tar.gz) = 3708
diff --git a/textproc/p5-XML-DOMHandler/pkg-descr b/textproc/p5-XML-DOMHandler/pkg-descr
new file mode 100644
index 000000000000..0bb0b9071c8d
--- /dev/null
+++ b/textproc/p5-XML-DOMHandler/pkg-descr
@@ -0,0 +1,6 @@
+This module creates a layer on top of DOM that allows you to program
+in a "push" style rather than "pull". Once the document has been parsed
+and you have a DOM object, you can call on the DOMHandler's traverse()
+method to apply a set of call-back routines to all the nodes in a tree.
+
+WWW: http://search.cpan.org/dist/XML-DOMHandler-1.0/
diff --git a/textproc/p5-XML-DOMHandler/pkg-plist b/textproc/p5-XML-DOMHandler/pkg-plist
new file mode 100644
index 000000000000..eb86ed6b28c8
--- /dev/null
+++ b/textproc/p5-XML-DOMHandler/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/DOMHandler/.packlist
+%%SITE_PERL%%/XML/DOMHandler.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/DOMHandler
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML