aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Descent
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-04-10 23:47:06 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-04-10 23:47:06 +0000
commit97c615ddee41db93f7d41d7285163be403f0ec4b (patch)
tree07e955d8460ee5eb20b2e963caf18dbec55cd21e /textproc/p5-XML-Descent
parent3a6702265414bf57fcf873dfbbc49202db5fdab9 (diff)
downloadports-97c615ddee41db93f7d41d7285163be403f0ec4b.tar.gz
ports-97c615ddee41db93f7d41d7285163be403f0ec4b.zip
- Perl library for recursive descent XML parsing.
WWW: http://search.cpan.org/dist/XML-Descent/ PR: ports/145602 Submitted by: Mike Bristow <mike@urgle.com> Approved by: itetcu (mentor, implicit)
Notes
Notes: svn path=/head/; revision=252539
Diffstat (limited to 'textproc/p5-XML-Descent')
-rw-r--r--textproc/p5-XML-Descent/Makefile25
-rw-r--r--textproc/p5-XML-Descent/distinfo3
-rw-r--r--textproc/p5-XML-Descent/pkg-descr3
-rw-r--r--textproc/p5-XML-Descent/pkg-plist3
4 files changed, 34 insertions, 0 deletions
diff --git a/textproc/p5-XML-Descent/Makefile b/textproc/p5-XML-Descent/Makefile
new file mode 100644
index 000000000000..c0c433ff85a5
--- /dev/null
+++ b/textproc/p5-XML-Descent/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: XML-TokeParser
+# Date created: 10 April 2010
+# Whom: Mike Bristow <mike@urgle.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Descent
+PORTVERSION= 1.04
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN/XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mike@urgle.com
+COMMENT= Recursive descent XML parsing
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/TokeParser.pm:${PORTSDIR}/textproc/p5-XML-TokeParser \
+ ${SITE_PERL}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences
+RUN_DEPENDS= ${SITE_PERL}/XML/TokeParser.pm:${PORTSDIR}/textproc/p5-XML-TokeParser
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Descent.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Descent/distinfo b/textproc/p5-XML-Descent/distinfo
new file mode 100644
index 000000000000..c28458dcd995
--- /dev/null
+++ b/textproc/p5-XML-Descent/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Descent-1.04.tar.gz) = 9e00f2c1a31d8cacd91fb23a30dc6fc6
+SHA256 (XML-Descent-1.04.tar.gz) = a711b856f8cdf5e647a44c71f967d48c096035b9dbd3f1efbdbea40605afbd50
+SIZE (XML-Descent-1.04.tar.gz) = 15212
diff --git a/textproc/p5-XML-Descent/pkg-descr b/textproc/p5-XML-Descent/pkg-descr
new file mode 100644
index 000000000000..acf53275e231
--- /dev/null
+++ b/textproc/p5-XML-Descent/pkg-descr
@@ -0,0 +1,3 @@
+Perl library for recursive descent XML parsing
+
+WWW: http://search.cpan.org/dist/XML-Descent/
diff --git a/textproc/p5-XML-Descent/pkg-plist b/textproc/p5-XML-Descent/pkg-plist
new file mode 100644
index 000000000000..b0159fd2a99d
--- /dev/null
+++ b/textproc/p5-XML-Descent/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Descent/.packlist
+%%SITE_PERL%%/XML/Descent.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Descent