aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Directory
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-12-07 12:45:27 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-12-07 12:45:27 +0000
commit335960c4e477934744974b0f7f63c0da9b4509d3 (patch)
treeddba8d7f8bc64fc18b36af102acf8d8c7405731b /textproc/p5-XML-Directory
parentc8d0e743592b17f8bd3880444f05d0bd4bfafb34 (diff)
downloadports-335960c4e477934744974b0f7f63c0da9b4509d3.tar.gz
ports-335960c4e477934744974b0f7f63c0da9b4509d3.zip
Add p5-XML-Directory 0.84, a perl module which returns a content of
a directory as XML. PR: 32163 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=51176
Diffstat (limited to 'textproc/p5-XML-Directory')
-rw-r--r--textproc/p5-XML-Directory/Makefile33
-rw-r--r--textproc/p5-XML-Directory/distinfo1
-rw-r--r--textproc/p5-XML-Directory/pkg-comment1
-rw-r--r--textproc/p5-XML-Directory/pkg-descr12
-rw-r--r--textproc/p5-XML-Directory/pkg-plist11
5 files changed, 58 insertions, 0 deletions
diff --git a/textproc/p5-XML-Directory/Makefile b/textproc/p5-XML-Directory/Makefile
new file mode 100644
index 000000000000..3492341d1480
--- /dev/null
+++ b/textproc/p5-XML-Directory/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: XML::Directory
+# Date created: 4 Sep 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Directory
+PORTVERSION= 0.84
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/RDF/Notation3.pm:${PORTSDIR}/textproc/p5-RDF-Notation3
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Directory.3 XML::Directory::Apache.3 \
+ XML::Directory::Exception.3 XML::Directory::SAX.3 \
+ XML::Directory::String.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @find ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ '$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$|@)(VERSION|ISA|EXPORT|EXPORT_OK)\s+=!$$1$${package}::$$2=!;'
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Directory/distinfo b/textproc/p5-XML-Directory/distinfo
new file mode 100644
index 000000000000..8210db148af2
--- /dev/null
+++ b/textproc/p5-XML-Directory/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Directory-0.84.tar.gz) = af3ce7168d7667d19f50e0b8a880d0e1
diff --git a/textproc/p5-XML-Directory/pkg-comment b/textproc/p5-XML-Directory/pkg-comment
new file mode 100644
index 000000000000..c7f2e8e005af
--- /dev/null
+++ b/textproc/p5-XML-Directory/pkg-comment
@@ -0,0 +1 @@
+Returns a content of directory as XML
diff --git a/textproc/p5-XML-Directory/pkg-descr b/textproc/p5-XML-Directory/pkg-descr
new file mode 100644
index 000000000000..560a6e1b375f
--- /dev/null
+++ b/textproc/p5-XML-Directory/pkg-descr
@@ -0,0 +1,12 @@
+This extension provides two classes: XML::Directory::String and
+XML::Directory::SAX. Their methods make it possible to set parameters
+such as level of details or maximal number of nested sub-directories
+and generate either string containing the resulting XML or SAX events.
+
+The SAX generator supports both SAX1 and SAX2 handlers. There are two
+SAX interfaces available: basic ContentHandler and optional ErrorHandler.
+
+WWW: http://search.cpan.org/search?dist=XML-Directory
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/textproc/p5-XML-Directory/pkg-plist b/textproc/p5-XML-Directory/pkg-plist
new file mode 100644
index 000000000000..211983800e95
--- /dev/null
+++ b/textproc/p5-XML-Directory/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Directory/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/Directory.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/Directory.pod
+lib/perl5/site_perl/%%PERL_VER%%/XML/Directory/Apache.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/Directory/Exception.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/Directory/SAX.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/Directory/String.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/XML/Directory
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Directory
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true