aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Filter-GenericChunk
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-08-28 20:39:14 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-08-28 20:39:14 +0000
commit909dcf3f1463ade4e85faa71ac7312a10a5a79a8 (patch)
tree13debd44cfe1faf00ebe03bc60d299637f98af50 /textproc/p5-XML-Filter-GenericChunk
parent0afc54a430fb52117c924d3422b766aa3c82f904 (diff)
downloadports-909dcf3f1463ade4e85faa71ac7312a10a5a79a8.tar.gz
ports-909dcf3f1463ade4e85faa71ac7312a10a5a79a8.zip
Add p5-XML-Filter-GenericChunk 0.06,
XML::Filter::GenericChunk is a base class for SAX filters that are able to Xparse wellballanced chunks from SAX events and transforms this chunk Xinto a sequence of SAX events. PR: 54729 Submitted by: Hansjoerg Pehofer <hansjoerg.pehofer@uibk.ac.at>
Notes
Notes: svn path=/head/; revision=87929
Diffstat (limited to 'textproc/p5-XML-Filter-GenericChunk')
-rw-r--r--textproc/p5-XML-Filter-GenericChunk/Makefile37
-rw-r--r--textproc/p5-XML-Filter-GenericChunk/distinfo1
-rw-r--r--textproc/p5-XML-Filter-GenericChunk/pkg-descr7
-rw-r--r--textproc/p5-XML-Filter-GenericChunk/pkg-plist9
4 files changed, 54 insertions, 0 deletions
diff --git a/textproc/p5-XML-Filter-GenericChunk/Makefile b/textproc/p5-XML-Filter-GenericChunk/Makefile
new file mode 100644
index 000000000000..db6da50b8977
--- /dev/null
+++ b/textproc/p5-XML-Filter-GenericChunk/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: XML::Filter::GenericChunk
+# Date created: 2.7.2003
+# Whom: Hansjoerg Pehofer <hansjoerg.pehofer@uibk.ac.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Filter-GenericChunk
+PORTVERSION= 0.06
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+#MASTER_SITE_SUBDIR= XML
+MASTER_SITE_SUBDIR= ../by-authors/id/P/PH/PHISH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hansjoerg.pehofer@uibk.ac.at
+COMMENT= "Base Class for SAX Filters parsing WellBallanced Chunks."
+
+BUILD_DEPENDS= ${PERL_ABASE}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/XML/SAX/Base.pm:${PORTSDIR}/textproc/p5-XML-SAX-Base
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+PERL_ABASE= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}
+
+MAN3= XML::Filter::CharacterChunk.3 \
+ XML::Filter::GenericChunk.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-Filter-GenericChunk/distinfo b/textproc/p5-XML-Filter-GenericChunk/distinfo
new file mode 100644
index 000000000000..7f09c071b48f
--- /dev/null
+++ b/textproc/p5-XML-Filter-GenericChunk/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Filter-GenericChunk-0.06.tar.gz) = 2177460740dd40690caf42000ab07a3b
diff --git a/textproc/p5-XML-Filter-GenericChunk/pkg-descr b/textproc/p5-XML-Filter-GenericChunk/pkg-descr
new file mode 100644
index 000000000000..66e4773928d5
--- /dev/null
+++ b/textproc/p5-XML-Filter-GenericChunk/pkg-descr
@@ -0,0 +1,7 @@
+XML::Filter::GenericChunk is a base class for SAX filters that are able to
+parse wellballanced chunks from SAX events and transforms this chunk
+into a sequence of SAX events.
+
+WWW: http://search.cpan.org/dist/XML-Filter-GenericChunk/
+
+Hansjoerg Pehofer <hansjoerg.pehofer@uibk.ac.at>
diff --git a/textproc/p5-XML-Filter-GenericChunk/pkg-plist b/textproc/p5-XML-Filter-GenericChunk/pkg-plist
new file mode 100644
index 000000000000..80e36d11ea31
--- /dev/null
+++ b/textproc/p5-XML-Filter-GenericChunk/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Filter/GenericChunk/.packlist
+%%SITE_PERL%%/XML/Filter/CharacterChunk.pm
+%%SITE_PERL%%/XML/Filter/GenericChunk.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Filter/GenericChunk
+@unexec rmdir %D/%%SITE_PERL%%/XML/Filter 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Filter/GenericChunk 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Filter 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true