aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Filter-SAX1toSAX2
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-06-02 13:54:56 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-06-02 13:54:56 +0000
commit6c503e91ab4bc6bcb5b6cea24d77b0f8f6980ac2 (patch)
treee83a577f6840e61cdb5bd56055c131b88da694db /textproc/p5-XML-Filter-SAX1toSAX2
parent0b4df6adcb40fc09cc8ca535b63706fe801ab8b1 (diff)
downloadports-6c503e91ab4bc6bcb5b6cea24d77b0f8f6980ac2.tar.gz
ports-6c503e91ab4bc6bcb5b6cea24d77b0f8f6980ac2.zip
Notes
Diffstat (limited to 'textproc/p5-XML-Filter-SAX1toSAX2')
-rw-r--r--textproc/p5-XML-Filter-SAX1toSAX2/Makefile25
-rw-r--r--textproc/p5-XML-Filter-SAX1toSAX2/distinfo1
-rw-r--r--textproc/p5-XML-Filter-SAX1toSAX2/pkg-comment1
-rw-r--r--textproc/p5-XML-Filter-SAX1toSAX2/pkg-descr8
-rw-r--r--textproc/p5-XML-Filter-SAX1toSAX2/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/p5-XML-Filter-SAX1toSAX2/Makefile b/textproc/p5-XML-Filter-SAX1toSAX2/Makefile
new file mode 100644
index 000000000000..bf0c14f28c60
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAX1toSAX2/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: XML-Filter-SAX1toSAX2
+# Date created: 02 June 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Filter-SAX1toSAX2
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/Filter/Base.pm:${PORTSDIR}/textproc/p5-XML-Filter-Base
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Filter::SAX1toSAX2.3 XML::Filter::SAX2toSAX1.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Filter-SAX1toSAX2/distinfo b/textproc/p5-XML-Filter-SAX1toSAX2/distinfo
new file mode 100644
index 000000000000..34bfd91c1a7e
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAX1toSAX2/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Filter-SAX1toSAX2-0.01.tar.gz) = bf5e2f3ff3d7c6289b81ed4450522745
diff --git a/textproc/p5-XML-Filter-SAX1toSAX2/pkg-comment b/textproc/p5-XML-Filter-SAX1toSAX2/pkg-comment
new file mode 100644
index 000000000000..67013427966d
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAX1toSAX2/pkg-comment
@@ -0,0 +1 @@
+Convert SAX1 events to SAX2
diff --git a/textproc/p5-XML-Filter-SAX1toSAX2/pkg-descr b/textproc/p5-XML-Filter-SAX1toSAX2/pkg-descr
new file mode 100644
index 000000000000..e910fca720c2
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAX1toSAX2/pkg-descr
@@ -0,0 +1,8 @@
+This module is a very simple module for creating SAX2 events from SAX1
+events. It is useful in the case where you have a SAX1 parser but want
+to use a SAX2 handler or filter of some sort.
+
+WWW: http://search.cpan.org/search?dist=XML-Filter-SAX1toSAX2
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/textproc/p5-XML-Filter-SAX1toSAX2/pkg-plist b/textproc/p5-XML-Filter-SAX1toSAX2/pkg-plist
new file mode 100644
index 000000000000..70f751d32e41
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAX1toSAX2/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter/SAX1toSAX2/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/Filter/SAX1toSAX2.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/Filter/SAX2toSAX1.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter/SAX1toSAX2
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/Filter 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true