aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Liberal
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-11 05:15:55 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-11 05:15:55 +0000
commit877f6dd7ea63a5f0fecfdfb44928cefbab6da6b5 (patch)
treeb4788bb5965f290a0bfb9b93cb238adca082c644 /textproc/p5-XML-Liberal
parentd282ddb0c6868b70199c61414c21534745fd19d8 (diff)
downloadports-877f6dd7ea63a5f0fecfdfb44928cefbab6da6b5.tar.gz
ports-877f6dd7ea63a5f0fecfdfb44928cefbab6da6b5.zip
Notes
Diffstat (limited to 'textproc/p5-XML-Liberal')
-rw-r--r--textproc/p5-XML-Liberal/Makefile34
-rw-r--r--textproc/p5-XML-Liberal/distinfo3
-rw-r--r--textproc/p5-XML-Liberal/pkg-descr5
-rw-r--r--textproc/p5-XML-Liberal/pkg-plist18
4 files changed, 60 insertions, 0 deletions
diff --git a/textproc/p5-XML-Liberal/Makefile b/textproc/p5-XML-Liberal/Makefile
new file mode 100644
index 000000000000..3b8ccb65c498
--- /dev/null
+++ b/textproc/p5-XML-Liberal/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-XML-Liberal
+# Date created: 2006-07-09
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Liberal
+PORTVERSION= 0.12
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Super liberal XML parser that parses broken XML
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/HTML/Entities/Numbered.pm:${PORTSDIR}/textproc/p5-HTML-Entities-Numbered \
+ ${SITE_PERL}/Module/Pluggable/Fast.pm:${PORTSDIR}/devel/p5-Module-Pluggable-Fast
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Liberal.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or higher
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-Liberal/distinfo b/textproc/p5-XML-Liberal/distinfo
new file mode 100644
index 000000000000..0b3a8cce8d20
--- /dev/null
+++ b/textproc/p5-XML-Liberal/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Liberal-0.12.tar.gz) = b7580d0a9afef6d7cb9e86840685cb5a
+SHA256 (XML-Liberal-0.12.tar.gz) = 1e06c6991734759d0909cc89200f5f63c8b42aa98738520c3b18a7b8f5b80848
+SIZE (XML-Liberal-0.12.tar.gz) = 44853
diff --git a/textproc/p5-XML-Liberal/pkg-descr b/textproc/p5-XML-Liberal/pkg-descr
new file mode 100644
index 000000000000..40565b35ba77
--- /dev/null
+++ b/textproc/p5-XML-Liberal/pkg-descr
@@ -0,0 +1,5 @@
+XML::Liberal is a super liberal XML parser that can fix broken XML
+stream and create a DOM node out of it.
+
+Author: Tatsuhiko Miyagawa <miyagawa@bulknews.net>
+WWW: http://search.cpan.org/dist/XML-Liberal/
diff --git a/textproc/p5-XML-Liberal/pkg-plist b/textproc/p5-XML-Liberal/pkg-plist
new file mode 100644
index 000000000000..fac00731991d
--- /dev/null
+++ b/textproc/p5-XML-Liberal/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Liberal/.packlist
+%%SITE_PERL%%/XML/Liberal.pm
+%%SITE_PERL%%/XML/Liberal/LibXML.pm
+%%SITE_PERL%%/XML/Liberal/Remedy.pm
+%%SITE_PERL%%/XML/Liberal/Remedy/EntityRef.pm
+%%SITE_PERL%%/XML/Liberal/Remedy/HTMLEntity.pm
+%%SITE_PERL%%/XML/Liberal/Remedy/InvalidEncoding.pm
+%%SITE_PERL%%/XML/Liberal/Remedy/NotUTF8.pm
+%%SITE_PERL%%/XML/Liberal/Remedy/StandaloneAttribute.pm
+%%SITE_PERL%%/XML/Liberal/Remedy/UndeclaredNS.pm
+%%SITE_PERL%%/XML/Liberal/Remedy/UnquotedAttribute.pm
+%%SITE_PERL%%/XML/Liberal/Remedy/XHTMLEmptyTag.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Liberal
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/Liberal/Remedy
+@dirrmtry %%SITE_PERL%%/XML/Liberal
+@dirrmtry %%SITE_PERL%%/XML