aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-SAX-Base
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-08 07:58:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-08 07:58:38 +0000
commit256fb825c25ddfc513ac072a2e5820f686f4e72c (patch)
tree4c4ce732215a72b110698a2778024faa8595d655 /textproc/p5-XML-SAX-Base
parent290d06a8a37f0ddee8f2d2c49444562fa64b5a49 (diff)
downloadports-256fb825c25ddfc513ac072a2e5820f686f4e72c.tar.gz
ports-256fb825c25ddfc513ac072a2e5820f686f4e72c.zip
- Re-add p5-XML-SAX-Base 1.08
XML::SAX::Base has a very simple task - to be a base class for PerlSAX drivers and filters. It's default behaviour is to pass the input directly to the output unchanged. It can be useful to use this module as a base class so you don't have to, for example, implement the characters() callback. The main advantages that it provides are easy dispatching of events the right way (ie it takes care for you of checking that the handler has implemented that method, or has defined an AUTOLOAD), and the guarantee that filters will pass along events that they aren't implementing to handlers downstream that might nevertheless be interested in them. WWW: http://search.cpan.org/dist/XML-SAX-Base/
Notes
Notes: svn path=/head/; revision=296213
Diffstat (limited to 'textproc/p5-XML-SAX-Base')
-rw-r--r--textproc/p5-XML-SAX-Base/Makefile29
-rw-r--r--textproc/p5-XML-SAX-Base/distinfo2
-rw-r--r--textproc/p5-XML-SAX-Base/pkg-descr12
-rw-r--r--textproc/p5-XML-SAX-Base/pkg-plist9
4 files changed, 52 insertions, 0 deletions
diff --git a/textproc/p5-XML-SAX-Base/Makefile b/textproc/p5-XML-SAX-Base/Makefile
new file mode 100644
index 000000000000..714a20f3a1fb
--- /dev/null
+++ b/textproc/p5-XML-SAX-Base/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-XML-SAX-Base
+# Date created: 2012-03-01
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-SAX-Base
+PORTVERSION= 1.08
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Base class SAX Drivers and Filters
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::SAX::Base.3 \
+ XML::SAX::BuildSAXBase.3 \
+ XML::SAX::Exception.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-SAX-Base/distinfo b/textproc/p5-XML-SAX-Base/distinfo
new file mode 100644
index 000000000000..c29237f48a48
--- /dev/null
+++ b/textproc/p5-XML-SAX-Base/distinfo
@@ -0,0 +1,2 @@
+SHA256 (XML-SAX-Base-1.08.tar.gz) = 666270318b15f88b8427e585198abbc19bc2e6ccb36dc4c0a4f2d9807330219e
+SIZE (XML-SAX-Base-1.08.tar.gz) = 28197
diff --git a/textproc/p5-XML-SAX-Base/pkg-descr b/textproc/p5-XML-SAX-Base/pkg-descr
new file mode 100644
index 000000000000..008e6af3ba17
--- /dev/null
+++ b/textproc/p5-XML-SAX-Base/pkg-descr
@@ -0,0 +1,12 @@
+XML::SAX::Base has a very simple task - to be a base class for PerlSAX drivers
+and filters. It's default behaviour is to pass the input directly to the output
+unchanged. It can be useful to use this module as a base class so you don't have
+to, for example, implement the characters() callback.
+
+The main advantages that it provides are easy dispatching of events the right
+way (ie it takes care for you of checking that the handler has implemented that
+method, or has defined an AUTOLOAD), and the guarantee that filters will pass
+along events that they aren't implementing to handlers downstream that might
+nevertheless be interested in them.
+
+WWW: http://search.cpan.org/dist/XML-SAX-Base/
diff --git a/textproc/p5-XML-SAX-Base/pkg-plist b/textproc/p5-XML-SAX-Base/pkg-plist
new file mode 100644
index 000000000000..f9fae390b200
--- /dev/null
+++ b/textproc/p5-XML-SAX-Base/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/XML/SAX/Base.pm
+%%SITE_PERL%%/XML/SAX/BuildSAXBase.pl
+%%SITE_PERL%%/XML/SAX/Exception.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/SAX/Base/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/SAX/Base
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/SAX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/SAX
+@dirrmtry %%SITE_PERL%%/XML