aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-SAX-Writer
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-12-07 13:10:55 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-12-07 13:10:55 +0000
commit020280043813af5805da27dc93eb803a23ff4a5a (patch)
tree69de1ee537a788b219a37e1c599724817676ab58 /textproc/p5-XML-SAX-Writer
parent0a79545d86713d96c67cf41be0ba57ba7820d3e7 (diff)
downloadports-020280043813af5805da27dc93eb803a23ff4a5a.tar.gz
ports-020280043813af5805da27dc93eb803a23ff4a5a.zip
Notes
Diffstat (limited to 'textproc/p5-XML-SAX-Writer')
-rw-r--r--textproc/p5-XML-SAX-Writer/Makefile28
-rw-r--r--textproc/p5-XML-SAX-Writer/distinfo1
-rw-r--r--textproc/p5-XML-SAX-Writer/pkg-comment1
-rw-r--r--textproc/p5-XML-SAX-Writer/pkg-descr6
-rw-r--r--textproc/p5-XML-SAX-Writer/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/textproc/p5-XML-SAX-Writer/Makefile b/textproc/p5-XML-SAX-Writer/Makefile
new file mode 100644
index 000000000000..14dcc7dc3ca4
--- /dev/null
+++ b/textproc/p5-XML-SAX-Writer/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: XML::SAX::Writer
+# Date created: 28 Nov 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-SAX-Writer
+PORTVERSION= 0.20
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/SAX/Exception.pm:${PORTSDIR}/textproc/p5-XML-SAX \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/NamespaceSupport.pm:${PORTSDIR}/textproc/p5-XML-NamespaceSupport \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::SAX::Writer.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-SAX-Writer/distinfo b/textproc/p5-XML-SAX-Writer/distinfo
new file mode 100644
index 000000000000..4ff5f8322617
--- /dev/null
+++ b/textproc/p5-XML-SAX-Writer/distinfo
@@ -0,0 +1 @@
+MD5 (XML-SAX-Writer-0.20.tar.gz) = c8825779cdad249c57a76dc9f9f0108b
diff --git a/textproc/p5-XML-SAX-Writer/pkg-comment b/textproc/p5-XML-SAX-Writer/pkg-comment
new file mode 100644
index 000000000000..24e8dfd06202
--- /dev/null
+++ b/textproc/p5-XML-SAX-Writer/pkg-comment
@@ -0,0 +1 @@
+SAX2 XML Writer
diff --git a/textproc/p5-XML-SAX-Writer/pkg-descr b/textproc/p5-XML-SAX-Writer/pkg-descr
new file mode 100644
index 000000000000..e96562ac7b66
--- /dev/null
+++ b/textproc/p5-XML-SAX-Writer/pkg-descr
@@ -0,0 +1,6 @@
+XML::SAX::Writer is SAX2 XML Writer.
+
+WWW: http://search.cpan.org/search?dist=XML-SAX-Writer
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/textproc/p5-XML-SAX-Writer/pkg-plist b/textproc/p5-XML-SAX-Writer/pkg-plist
new file mode 100644
index 000000000000..abf64f81be15
--- /dev/null
+++ b/textproc/p5-XML-SAX-Writer/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX/Writer/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/Writer.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX/Writer
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/SAX 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true