aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-SimpleObject
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-09-05 07:25:04 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-09-05 07:25:04 +0000
commite15afee535ffec38424947ba1c7eb0ada4141fc2 (patch)
tree563a5f91ae0809c62bd3613674f6becd0ca1ffab /textproc/p5-XML-SimpleObject
parent35769418568a623fdb6c8a321eb2be9c24324094 (diff)
downloadports-e15afee535ffec38424947ba1c7eb0ada4141fc2.tar.gz
ports-e15afee535ffec38424947ba1c7eb0ada4141fc2.zip
Fix build on perl 5.005_03
Reported by: Mark Linimon <linimon@lonesome.com>
Notes
Notes: svn path=/head/; revision=88580
Diffstat (limited to 'textproc/p5-XML-SimpleObject')
-rw-r--r--textproc/p5-XML-SimpleObject/Makefile5
-rw-r--r--textproc/p5-XML-SimpleObject/files/patch-Enhanced-Makefile.PL9
-rw-r--r--textproc/p5-XML-SimpleObject/files/patch-LibXML-Makefile.PL9
-rw-r--r--textproc/p5-XML-SimpleObject/files/patch-Makefile.PL9
4 files changed, 31 insertions, 1 deletions
diff --git a/textproc/p5-XML-SimpleObject/Makefile b/textproc/p5-XML-SimpleObject/Makefile
index 2b592142c1c9..4017ab8c3ebe 100644
--- a/textproc/p5-XML-SimpleObject/Makefile
+++ b/textproc/p5-XML-SimpleObject/Makefile
@@ -24,6 +24,9 @@ PERL_CONFIGURE= YES
CONFIGURE_ARGS+= DIR='Enhanced'
MAN3= XML::SimpleObject.3
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
+ ${WRKSRC}/SimpleObject.pm ${WRKSRC}/LibXML/LibXML.pm
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-SimpleObject/files/patch-Enhanced-Makefile.PL b/textproc/p5-XML-SimpleObject/files/patch-Enhanced-Makefile.PL
new file mode 100644
index 000000000000..5aa9fed5e7f0
--- /dev/null
+++ b/textproc/p5-XML-SimpleObject/files/patch-Enhanced-Makefile.PL
@@ -0,0 +1,9 @@
+--- Enhanced/Makefile.PL.orig Fri Sep 5 09:20:57 2003
++++ Enhanced/Makefile.PL Fri Sep 5 09:21:13 2003
+@@ -4,5 +4,5 @@
+
+ WriteMakefile(
+ 'NAME' => 'XML::SimpleObject::Enhanced',
+- 'VERSION_FROM' => 'Enhanced.pm', # finds $VERSION
++ 'VERSION' => '0.53',
+ );
diff --git a/textproc/p5-XML-SimpleObject/files/patch-LibXML-Makefile.PL b/textproc/p5-XML-SimpleObject/files/patch-LibXML-Makefile.PL
new file mode 100644
index 000000000000..e5e88380764a
--- /dev/null
+++ b/textproc/p5-XML-SimpleObject/files/patch-LibXML-Makefile.PL
@@ -0,0 +1,9 @@
+--- LibXML/Makefile.PL.orig Fri Sep 5 09:11:38 2003
++++ LibXML/Makefile.PL Fri Sep 5 09:11:56 2003
+@@ -9,5 +9,5 @@
+ print "OK\n";
+ WriteMakefile(
+ 'NAME' => 'XML::SimpleObject::LibXML',
+- 'VERSION_FROM' => 'LibXML.pm', # finds $VERSION
++ 'VERSION' => '0.53',
+ );
diff --git a/textproc/p5-XML-SimpleObject/files/patch-Makefile.PL b/textproc/p5-XML-SimpleObject/files/patch-Makefile.PL
new file mode 100644
index 000000000000..0a46284e9f30
--- /dev/null
+++ b/textproc/p5-XML-SimpleObject/files/patch-Makefile.PL
@@ -0,0 +1,9 @@
+--- Makefile.PL.orig Fri Sep 5 09:09:14 2003
++++ Makefile.PL Fri Sep 5 09:09:41 2003
+@@ -9,5 +9,5 @@
+
+ WriteMakefile(
+ 'NAME' => 'XML::SimpleObject',
+- 'VERSION_FROM' => 'SimpleObject.pm', # finds $VERSION
++ 'VERSION' => '0.53',
+ );