aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-TreePP
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 07:23:45 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 07:23:45 +0000
commit6c1fbb75ccb3467e58f7349f860a7590af25137f (patch)
tree7cea923535802d0249e53362b5aba891cdb962d2 /textproc/p5-XML-TreePP
parent192e45a1507019e7d9b53a9a69e2d150a54a6277 (diff)
downloadports-6c1fbb75ccb3467e58f7349f860a7590af25137f.tar.gz
ports-6c1fbb75ccb3467e58f7349f860a7590af25137f.zip
Add p5-XML-TreePP 0.18, pure Perl implementation for parsing/writing xml
files. PR: ports/101990 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=170554
Diffstat (limited to 'textproc/p5-XML-TreePP')
-rw-r--r--textproc/p5-XML-TreePP/Makefile27
-rw-r--r--textproc/p5-XML-TreePP/distinfo3
-rw-r--r--textproc/p5-XML-TreePP/pkg-descr6
-rw-r--r--textproc/p5-XML-TreePP/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/p5-XML-TreePP/Makefile b/textproc/p5-XML-TreePP/Makefile
new file mode 100644
index 000000000000..17d1042c36ac
--- /dev/null
+++ b/textproc/p5-XML-TreePP/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-XML-TreePP
+# Date created: 2006-08-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-TreePP
+PORTVERSION= 0.18
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Pure Perl implementation for parsing/writing xml files
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::TreePP.3
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/example/envxml.cgi ${EXAMPLESDIR}
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-TreePP/distinfo b/textproc/p5-XML-TreePP/distinfo
new file mode 100644
index 000000000000..1930cf01536c
--- /dev/null
+++ b/textproc/p5-XML-TreePP/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-TreePP-0.18.tar.gz) = 55b96d263a655f2c4f947f8230c7165f
+SHA256 (XML-TreePP-0.18.tar.gz) = 963d8125289058e7780eefcfa0cb6f62117b3419456f4bd648082790c41b0e20
+SIZE (XML-TreePP-0.18.tar.gz) = 24688
diff --git a/textproc/p5-XML-TreePP/pkg-descr b/textproc/p5-XML-TreePP/pkg-descr
new file mode 100644
index 000000000000..bd51f07b114b
--- /dev/null
+++ b/textproc/p5-XML-TreePP/pkg-descr
@@ -0,0 +1,6 @@
+XML::TreePP module parses XML file and expands it for a hash tree. And
+also generate XML file from a hash tree. This is a pure Perl
+implementation. You can also download XML from remote web server like
+XMLHttpRequest object at JavaScript language.
+
+WWW: http://search.cpan.org/dist/XML-TreePP/
diff --git a/textproc/p5-XML-TreePP/pkg-plist b/textproc/p5-XML-TreePP/pkg-plist
new file mode 100644
index 000000000000..2e3075cf87b8
--- /dev/null
+++ b/textproc/p5-XML-TreePP/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%EXAMPLESDIR%%/envxml.cgi
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML-TreePP/.packlist
+%%SITE_PERL%%/XML/TreePP.pm
+@dirrm %%EXAMPLESDIR%%
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML-TreePP
+@dirrmtry %%SITE_PERL%%/XML