aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-XML2JSON
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-10-07 15:25:11 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-10-07 15:25:11 +0000
commit99baa8d2a7ed1718f7cb29de81ae94210bd6b849 (patch)
treef41761f97da5c490c15dcb99b0be669223b03490 /textproc/p5-XML-XML2JSON
parent13a0dc80f8d879646d8bf384e73319b9f7876348 (diff)
downloadports-99baa8d2a7ed1718f7cb29de81ae94210bd6b849.tar.gz
ports-99baa8d2a7ed1718f7cb29de81ae94210bd6b849.zip
- Add LICENSE
- Convert to new options framework - Fix typo - Cleanup Makefile header
Notes
Notes: svn path=/head/; revision=305492
Diffstat (limited to 'textproc/p5-XML-XML2JSON')
-rw-r--r--textproc/p5-XML-XML2JSON/Makefile31
1 files changed, 16 insertions, 15 deletions
diff --git a/textproc/p5-XML-XML2JSON/Makefile b/textproc/p5-XML-XML2JSON/Makefile
index 0f90a8a1ad19..3940b8767940 100644
--- a/textproc/p5-XML-XML2JSON/Makefile
+++ b/textproc/p5-XML-XML2JSON/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-XML-XML2JSON
-# Date created: 2011-07-11
-# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-#
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= XML-XML2JSON
PORTVERSION= 0.06
@@ -14,14 +10,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Convert XML into JSON (and back again) using XML::LibXML
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
BUILD_DEPENDS= p5-XML-LibXML>=1.59:${PORTSDIR}/textproc/p5-XML-LibXML
-RUN_DEPENDS= p5-XML-LibXML>=1.59:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS:= ${BUILD_DEPENDS}
# the order of options follows the search order of JSON module by XML::XML2JSON
-OPTIONS= JSON_SYCK "Use JSON::Syck" on \
- JSON_XS "Use JSON::XS" off \
- JSON "Use JSON" off \
- JSON_DWIW "Use JSON::DWIW" off
+OPTIONS_DEFINE= JSON_SYCK JSON_XS JSON JSON_DWIW
+OPTIONS_DEFAULT=JSON_SYCK
+JSON_SYCK_DESC= Use JSON::Syck
+JSON_XS_DESC= Use JSON::XS
+JSON_DESC= Use JSON
+JSON_DWIW_DESC= Use JSON::DWIW
PERL_CONFIGURE= yes
@@ -29,26 +30,26 @@ MAN3= XML::XML2JSON.3
.include <bsd.port.options.mk>
-.if defined(WITHOUT_JSON_SYCK) && !defined(WITH_JSON_XS) && !defined(WITH_JSON) && !defined(WITH_JSON_DWIW)
+.if empty(PORT_OPTIONS:MJSON_SYCK) && empty(PORT_OPTIONS:MJSON_XS) && empty(PORT_OPTIONS:MJSON) && empty(PORT_OPTIONS:MJSON_DWIW)
IGNORE= you must choose at least one JSON module
.endif
-.if !defined(WITHOUT_JSON_SYCK)
+.if ${PORT_OPTIONS:MJSON_SYCK}
BUILD_DEPENDS+= p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
RUN_DEPENDS+= p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
.endif
-.if defined(WITH_JSON_XS)
+.if ${PORT_OPTIONS:MJSON_XS}
BUILD_DEPENDS+= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS
RUN_DEPENDS+= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS
.endif
-.if defined(WITH_JSON)
+.if ${PORT_OPTIONS:MJSON}
BUILD_DEPENDS+= p5-JSON>=0:${PORTSDIR}/converters/p5-JSON
RUN_DEPENDS+= p5-JSON>=0:${PORTSDIR}/converters/p5-JSON
.endif
-.if defined(WITH_JSON_)
+.if ${PORT_OPTIONS:MJSON_DWIW}
BUILD_DEPENDS+= p5-JSON-DWIW>=0:${PORTSDIR}/converters/p5-JSON-DWIW
RUN_DEPENDS+= p5-JSON-DWIW>=0:${PORTSDIR}/converters/p5-JSON-DWIW
.endif