aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-XSH/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-07-17 10:15:47 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-07-17 10:15:47 +0000
commit182408e7f4035575a62e5ef8d779492e56781313 (patch)
treec7e848eb0d09599841be43c038e40d76cf9f1afe /textproc/p5-XML-XSH/Makefile
parent6da4fb96fa0e8a46e51f7caf21f1823ab5a51d1f (diff)
downloadports-182408e7f4035575a62e5ef8d779492e56781313.tar.gz
ports-182408e7f4035575a62e5ef8d779492e56781313.zip
Notes
Diffstat (limited to 'textproc/p5-XML-XSH/Makefile')
-rw-r--r--textproc/p5-XML-XSH/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/p5-XML-XSH/Makefile b/textproc/p5-XML-XSH/Makefile
new file mode 100644
index 000000000000..21d6bed93f71
--- /dev/null
+++ b/textproc/p5-XML-XSH/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: XML::XSH
+# Date created: 15 July 2002
+# Whom: Lev Serebryakov <lev@serebryakov.spb.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-XSH
+PORTVERSION= 1.4
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lev@serebryakov.spb.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/XUpdate/LibXML.pm:${PORTSDIR}/textproc/p5-XML-XUpdate-LibXML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+post-patch:
+ @${PERL} -pi -e 's/^(?=no warnings;)/#/ if $$.==6' \
+ ${WRKSRC}/lib/XML/XSH/Functions.pm
+
+.include <bsd.port.mk>