aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-xmltv
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-03-03 15:56:17 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-03-03 15:56:17 +0000
commit7008f4db052d22859c5d6dee8b8c76a51e38e492 (patch)
treedcc2aead1abb1785680f748bb8b5ae172e09be68 /textproc/p5-xmltv
parent0df31d5764c2c9d0193dce180ead71ee3cabcebc (diff)
downloadports-7008f4db052d22859c5d6dee8b8c76a51e38e492.tar.gz
ports-7008f4db052d22859c5d6dee8b8c76a51e38e492.zip
Update to 0.5.59.
fix RUN_DEPENDS=${BUILD_DEPENDS} issue.
Notes
Notes: svn path=/head/; revision=270204
Diffstat (limited to 'textproc/p5-xmltv')
-rw-r--r--textproc/p5-xmltv/Makefile24
-rw-r--r--textproc/p5-xmltv/distinfo5
-rw-r--r--textproc/p5-xmltv/files/patch-Makefile.PL14
-rw-r--r--textproc/p5-xmltv/pkg-plist9
4 files changed, 28 insertions, 24 deletions
diff --git a/textproc/p5-xmltv/Makefile b/textproc/p5-xmltv/Makefile
index 217c70c1374d..90266977a951 100644
--- a/textproc/p5-xmltv/Makefile
+++ b/textproc/p5-xmltv/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmltv
-PORTVERSION= 0.5.57
+PORTVERSION= 0.5.59
CATEGORIES= textproc perl5
MASTER_SITES= SF
PKGNAMEPREFIX= p5-
@@ -14,12 +14,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Set of programs to process TV (tvguide) listings in XML format
-BUILD_DEPENDS= \
+XMLTV_DEPENDS= \
${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig \
${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ ${SITE_PERL}/${PERL_ARCH}/PerlIO/gzip.pm:${PORTSDIR}/archivers/p5-PerlIO-gzip \
+ ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
+ ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-IO-Compress \
+ ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/${PERL_ARCH}/Tk/TableMatrix.pm:${PORTSDIR}/x11-toolkits/p5-Tk-TableMatrix \
@@ -28,7 +33,6 @@ BUILD_DEPENDS= \
${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite \
${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
${SITE_PERL}/HTML/TableExtract.pm:${PORTSDIR}/www/p5-HTML-TableExtract \
- ${SITE_PERL}/HTML/LinkExtractor.pm:${PORTSDIR}/www/p5-HTML-LinkExtractor \
${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
${SITE_PERL}/Term/ProgressBar.pm:${PORTSDIR}/devel/p5-Term-ProgressBar \
${SITE_PERL}/Lingua/Preferred.pm:${PORTSDIR}/textproc/p5-Lingua-Preferred \
@@ -37,10 +41,10 @@ BUILD_DEPENDS= \
${SITE_PERL}/Lingua/EN/Numbers/Ordinate.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Numbers-Ordinate \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
${SITE_PERL}/HTTP/Cache/Transparent.pm:${PORTSDIR}/www/p5-HTTP-Cache-Transparent \
- ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
- ${SITE_PERL}/${PERL_ARCH}/Text/Bidi.pm:${PORTSDIR}/converters/p5-Text-Bidi
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ ${SITE_PERL}/IO/Stringy.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
+BUILD_DEPENDS= ${XMLTV_DEPENDS}
+RUN_DEPENDS= ${XMLTV_DEPENDS}
USE_BZIP2= yes
PERL_CONFIGURE= yes
@@ -60,13 +64,13 @@ PORTDOCS= COPYING \
.endif
MAN1= tv_cat.1 tv_check.1 tv_extractinfo_ar.1 tv_extractinfo_en.1 \
- tv_find_grabbers.1 tv_grab_ar.1 \
+ tv_find_grabbers.1 \
tv_grab_ch_search.1 tv_grab_combiner.1 tv_grab_dk_dr.1 \
tv_grab_dtv_la.1 tv_grab_ee.1 tv_grab_es_laguiatv.1 \
- tv_grab_es_miguiatv.1 tv_grab_fi.1 tv_grab_fr.1 tv_grab_hr.1 \
+ tv_grab_es_miguiatv.1 tv_grab_fi.1 tv_grab_fi_sv.1 tv_grab_fr.1 tv_grab_hr.1 \
tv_grab_huro.1 tv_grab_il.1 tv_grab_in.1 tv_grab_it.1 tv_grab_it_dvb.1 \
tv_grab_is.1 tv_grab_na_dd.1 tv_grab_na_icons.1 tv_grab_nl.1 \
- tv_grab_no_gfeed.1 tv_grab_pt.1 tv_grab_re.1 tv_grab_se_swedb.1 \
+ tv_grab_no_gfeed.1 tv_grab_pt.1 tv_grab_pt_meo.1 tv_grab_re.1 tv_grab_se_swedb.1 \
tv_grab_uk_bleb.1 tv_grab_uk_rt.1 tv_grab_za.1 tv_grep.1 tv_imdb.1 \
tv_remove_some_overlapping.1 tv_sort.1 tv_split.1 tv_to_latex.1 \
tv_to_potatoe.1 tv_to_text.1 tv_validate_file.1 \
diff --git a/textproc/p5-xmltv/distinfo b/textproc/p5-xmltv/distinfo
index 0c2c17c986d4..d019b76bacf0 100644
--- a/textproc/p5-xmltv/distinfo
+++ b/textproc/p5-xmltv/distinfo
@@ -1,3 +1,2 @@
-MD5 (xmltv-0.5.57.tar.bz2) = c8396db9f823ba43d42ca3f4662b816b
-SHA256 (xmltv-0.5.57.tar.bz2) = 4a42a1d239caa988fc6d25414ff0104aa831ffa273d4a571cff8c76c05e0afd3
-SIZE (xmltv-0.5.57.tar.bz2) = 778254
+SHA256 (xmltv-0.5.59.tar.bz2) = 36ffdc94561c2ec49615cf8379f3d6c83096bd0ba83a6c14d77423106c5c3b37
+SIZE (xmltv-0.5.59.tar.bz2) = 839866
diff --git a/textproc/p5-xmltv/files/patch-Makefile.PL b/textproc/p5-xmltv/files/patch-Makefile.PL
index b18e12d81352..68bf0143138c 100644
--- a/textproc/p5-xmltv/files/patch-Makefile.PL
+++ b/textproc/p5-xmltv/files/patch-Makefile.PL
@@ -1,11 +1,11 @@
---- Makefile.PL.orig Mon Feb 27 15:53:11 2006
-+++ Makefile.PL Mon Feb 27 15:56:50 2006
-@@ -537,14 +537,14 @@ END
+--- Makefile.PL.orig 2010-11-22 07:04:58.000000000 +0100
++++ Makefile.PL 2011-03-03 14:50:27.000000000 +0100
+@@ -804,14 +804,14 @@
# Guess a default value for {install} based on whether
# prerequisites were found.
#
-- $info->{install} = $opt_yes || not $info->{missing};
-+ $info->{install} = 1; #$opt_yes || not $info->{missing};
+- $info->{install} = (not $info->{exclude}) && ($opt_yes || not $info->{missing});
++ $info->{install} = 1;(not $info->{exclude}) && ($opt_yes || not $info->{missing});
print STDERR ($s, ' ' x (1 + $width - length $s),
$info->{install} ? '[yes]' : '[no]',
@@ -17,7 +17,7 @@
# Need to set {install} for each component by prompting.
foreach my $info (@opt_components) {
my $missing = $info->{missing};
-@@ -573,8 +573,8 @@ END
+@@ -840,8 +840,8 @@
die;
}
@@ -28,7 +28,7 @@
}
}
}
-@@ -778,8 +778,8 @@ END
+@@ -1045,8 +1045,8 @@
}
# Remove existing non-working 'uninstall' target.
diff --git a/textproc/p5-xmltv/pkg-plist b/textproc/p5-xmltv/pkg-plist
index f102824ff5a4..d2831f38fb1d 100644
--- a/textproc/p5-xmltv/pkg-plist
+++ b/textproc/p5-xmltv/pkg-plist
@@ -3,7 +3,6 @@ bin/tv_check
bin/tv_extractinfo_ar
bin/tv_extractinfo_en
bin/tv_find_grabbers
-bin/tv_grab_ar
bin/tv_grab_ch_search
bin/tv_grab_combiner
bin/tv_grab_dk_dr
@@ -13,6 +12,7 @@ bin/tv_grab_es_laguiatv
bin/tv_grab_es_miguiatv
bin/tv_grab_eu_epgdata
bin/tv_grab_fi
+bin/tv_grab_fi_sv
bin/tv_grab_fr
bin/tv_grab_hr
bin/tv_grab_huro
@@ -27,6 +27,7 @@ bin/tv_grab_na_icons
bin/tv_grab_nl
bin/tv_grab_no_gfeed
bin/tv_grab_pt
+bin/tv_grab_pt_meo
bin/tv_grab_re
bin/tv_grab_se_swedb
bin/tv_grab_uk_bleb
@@ -77,7 +78,6 @@ bin/tv_validate_grabber
%%SITE_PERL%%/XMLTV/ValidateGrabber.pm
%%SITE_PERL%%/XMLTV/Version.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/XMLTV/.packlist
-%%DATADIR%%/tv_grab_ch_search/channel_ids
%%DATADIR%%/tv_grab_eu_epgdata/channel_ids
%%DATADIR%%/tv_grab_huro/catmap.cz
%%DATADIR%%/tv_grab_huro/catmap.hu
@@ -85,26 +85,27 @@ bin/tv_validate_grabber
%%DATADIR%%/tv_grab_huro/catmap.sk
%%DATADIR%%/tv_grab_huro/jobmap
%%DATADIR%%/tv_grab_it/channel_ids
-%%DATADIR%%/tv_grab_it_dvb/channel_ids
%%DATADIR%%/tv_grab_it_dvb/sky_it.dict
%%DATADIR%%/tv_grab_it_dvb/sky_it.themes
%%DATADIR%%/tv_grab_it_dvb/channel_ids
%%DATADIR%%/tv_grab_uk_bleb/icon_urls
%%DATADIR%%/tv_grab_uk_rt/channel_ids
%%DATADIR%%/tv_grab_uk_rt/channels_platforms
+%%DATADIR%%/tv_grab_uk_rt/lineups/freesat.map
+%%DATADIR%%/tv_grab_uk_rt/lineups/freeview.map
%%DATADIR%%/tv_grab_uk_rt/prog_titles_to_process
%%DATADIR%%/tv_grab_uk_rt/regional_channels_by_postcode
%%DATADIR%%/tv_grab_uk_rt/utf8_fixups
%%DATADIR%%/xmltv.dtd
%%DATADIR%%/xmltv-lineup.dtd
www/cgi-bin/tv_pick.cgi
+@dirrm %%DATADIR%%/tv_grab_uk_rt/lineups
@dirrm %%DATADIR%%/tv_grab_uk_rt
@dirrm %%DATADIR%%/tv_grab_uk_bleb
@dirrm %%DATADIR%%/tv_grab_it_dvb
@dirrm %%DATADIR%%/tv_grab_it
@dirrm %%DATADIR%%/tv_grab_huro
@dirrm %%DATADIR%%/tv_grab_eu_epgdata
-@dirrm %%DATADIR%%/tv_grab_ch_search
@dirrm %%DATADIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XMLTV
@dirrm %%SITE_PERL%%/XMLTV/ProgressBar