aboutsummaryrefslogtreecommitdiff
path: root/textproc/pdftohtml
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-12-07 14:26:20 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-12-07 14:26:20 +0000
commitcc462d5a8ab1661227b82e5b92d313a3125c5114 (patch)
treef05b7f4b613a62ea3d6bab0f60a10e534d946883 /textproc/pdftohtml
parent4a0a39807224f6787362971d926e6474d5cb9e15 (diff)
downloadports-cc462d5a8ab1661227b82e5b92d313a3125c5114.tar.gz
ports-cc462d5a8ab1661227b82e5b92d313a3125c5114.zip
Backport xpdf vendor patch (affected part)
Notes
Notes: svn path=/head/; revision=150591
Diffstat (limited to 'textproc/pdftohtml')
-rw-r--r--textproc/pdftohtml/Makefile2
-rw-r--r--textproc/pdftohtml/files/patch-SA1789793
2 files changed, 94 insertions, 1 deletions
diff --git a/textproc/pdftohtml/Makefile b/textproc/pdftohtml/Makefile
index c8a0501f5c70..10a33aca1771 100644
--- a/textproc/pdftohtml/Makefile
+++ b/textproc/pdftohtml/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pdftohtml
PORTVERSION= 0.36
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/textproc/pdftohtml/files/patch-SA17897 b/textproc/pdftohtml/files/patch-SA17897
new file mode 100644
index 000000000000..97cf8894bf2d
--- /dev/null
+++ b/textproc/pdftohtml/files/patch-SA17897
@@ -0,0 +1,93 @@
+--- xpdf/Stream.cc.orig Mon May 17 16:37:57 2004
++++ xpdf/Stream.cc Tue Dec 6 18:05:14 2005
+@@ -407,18 +407,33 @@
+
+ StreamPredictor::StreamPredictor(Stream *strA, int predictorA,
+ int widthA, int nCompsA, int nBitsA) {
++ int totalBits;
++
+ str = strA;
+ predictor = predictorA;
+ width = widthA;
+ nComps = nCompsA;
+ nBits = nBitsA;
++ predLine = NULL;
++ ok = gFalse;
+
+ nVals = width * nComps;
++ totalBits = nVals * nBits;
++ if (totalBits == 0 ||
++ (totalBits / nBits) / nComps != width ||
++ totalBits + 7 < 0) {
++ return;
++ }
+ pixBytes = (nComps * nBits + 7) >> 3;
+- rowBytes = ((nVals * nBits + 7) >> 3) + pixBytes;
++ rowBytes = ((totalBits + 7) >> 3) + pixBytes;
++ if (rowBytes < 0) {
++ return;
++ }
+ predLine = (Guchar *)gmalloc(rowBytes);
+ memset(predLine, 0, rowBytes);
+ predIdx = rowBytes;
++
++ ok = gTrue;
+ }
+
+ StreamPredictor::~StreamPredictor() {
+@@ -1012,6 +1027,10 @@
+ FilterStream(strA) {
+ if (predictor != 1) {
+ pred = new StreamPredictor(this, predictor, columns, colors, bits);
++ if (!pred->isOk()) {
++ delete pred;
++ pred = NULL;
++ }
+ } else {
+ pred = NULL;
+ }
+@@ -2897,6 +2916,14 @@
+ height = read16();
+ width = read16();
+ numComps = str->getChar();
++ if (numComps <= 0 || numComps > 4) {
++ error(getPos(), "Bad number of components in DCT stream", prec);
++ return gFalse;
++ }
++ if (numComps <= 0 || numComps > 4) {
++ error(getPos(), "Bad number of components in DCT stream", prec);
++ return gFalse;
++ }
+ if (prec != 8) {
+ error(getPos(), "Bad DCT precision %d", prec);
+ return gFalse;
+@@ -3255,6 +3282,10 @@
+ FilterStream(strA) {
+ if (predictor != 1) {
+ pred = new StreamPredictor(this, predictor, columns, colors, bits);
++ if (!pred->isOk()) {
++ delete pred;
++ pred = NULL;
++ }
+ } else {
+ pred = NULL;
+ }
+--- xpdf/Stream.h.orig Mon May 17 16:37:57 2004
++++ xpdf/Stream.h Tue Dec 6 18:05:14 2005
+@@ -233,6 +233,8 @@
+
+ ~StreamPredictor();
+
++ GBool isOk() { return ok; }
++
+ int lookChar();
+ int getChar();
+
+@@ -250,6 +252,7 @@
+ int rowBytes; // bytes per line
+ Guchar *predLine; // line buffer
+ int predIdx; // current index in predLine
++ GBool ok;
+ };
+
+ //------------------------------------------------------------------------