aboutsummaryrefslogtreecommitdiff
path: root/textproc/pecl-syck
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-04 02:47:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-04 02:47:35 +0000
commite330157ba8077c233888fe665f2da16e5a746f43 (patch)
tree78c8cf9ffa608938e57f20fd428b6277b7523b17 /textproc/pecl-syck
parentd5b10017d19ee836c9755d34c734fc3b86f08d98 (diff)
downloadports-e330157ba8077c233888fe665f2da16e5a746f43.tar.gz
ports-e330157ba8077c233888fe665f2da16e5a746f43.zip
Notes
Diffstat (limited to 'textproc/pecl-syck')
-rw-r--r--textproc/pecl-syck/Makefile9
-rw-r--r--textproc/pecl-syck/files/patch-phpext.c38
2 files changed, 40 insertions, 7 deletions
diff --git a/textproc/pecl-syck/Makefile b/textproc/pecl-syck/Makefile
index 85b7f0daaf67..1b5fe18948d2 100644
--- a/textproc/pecl-syck/Makefile
+++ b/textproc/pecl-syck/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: pecl-syck
-# Date created: 7 Aug 2007
-# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
-#
+# Created by: Ditesh Shashikant Gathani <ditesh@gathani.org>
# $FreeBSD$
-#
PORTNAME= syck
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= textproc pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -21,8 +18,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libsyck.a:${PORTSDIR}/textproc/syck
USE_PHP= spl hash
USE_PHP_BUILD= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-syck
diff --git a/textproc/pecl-syck/files/patch-phpext.c b/textproc/pecl-syck/files/patch-phpext.c
new file mode 100644
index 000000000000..2f377eb0eba3
--- /dev/null
+++ b/textproc/pecl-syck/files/patch-phpext.c
@@ -0,0 +1,38 @@
+--- phpext.c.orig 2012-12-05 11:19:34.767180000 +0800
++++ phpext.c 2012-12-05 11:20:01.379824000 +0800
+@@ -198,7 +198,7 @@
+
+
+
+-function_entry syck_functions[] = {
++zend_function_entry syck_functions[] = {
+ PHP_FE(syck_load, arginfo_syck_load)
+ PHP_FE(syck_dump, arginfo_syck_dump)
+ {NULL, NULL, NULL} /* Must be the last line in syck_functions[] */
+@@ -403,7 +403,7 @@
+
+ strncpy(classname, n->type_id + 12, classname_len + 1);
+
+- if (FAILURE == zend_lookup_class_ex(classname, classname_len, 1, &ce TSRMLS_CC)) {
++ if (FAILURE == zend_lookup_class(classname, classname_len, &ce TSRMLS_CC)) {
+ zend_throw_exception_ex(syck_exception_entry, 0 TSRMLS_CC, "Couldn't find %s class on line %d, col %d: '%s'", classname, p->linect + 1, p->cursor - p->lineptr, p->lineptr);
+ efree(classname);
+ break;
+@@ -439,7 +439,7 @@
+
+ strncpy(classname, n->type_id + 11, classname_len + 1);
+
+- if (FAILURE == zend_lookup_class_ex(classname, classname_len, 1, &ce TSRMLS_CC)) {
++ if (FAILURE == zend_lookup_class(classname, classname_len, &ce TSRMLS_CC)) {
+ zend_throw_exception_ex(syck_exception_entry, 0 TSRMLS_CC, "Couldn't find %s class on line %d, col %d: '%s'", classname, p->linect + 1, p->cursor - p->lineptr, p->lineptr);
+ efree(classname);
+ break;
+@@ -511,7 +511,7 @@
+
+ strncpy(classname, n->type_id + 10, classname_len + 1);
+
+- if (FAILURE == zend_lookup_class_ex(classname, classname_len, 1, &ce TSRMLS_CC)) {
++ if (FAILURE == zend_lookup_class(classname, classname_len, &ce TSRMLS_CC)) {
+ zend_throw_exception_ex(syck_exception_entry, 0 TSRMLS_CC, "Couldn't find %s class on line %d, col %d: '%s'", classname, p->linect + 1, p->cursor - p->lineptr, p->lineptr);
+ efree(classname);
+ break;