aboutsummaryrefslogtreecommitdiff
path: root/textproc/php80-simplexml
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2020-10-21 22:58:51 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2020-10-21 22:58:51 +0000
commit1061308ba7160b89e64adf0349a3a297137e9a8b (patch)
tree7759eddebe7bd2de031762b7cab386e48e4b52b4 /textproc/php80-simplexml
parent93f3c1aa069f89a5fbd0b32fa4e9e851cc62e84b (diff)
downloadports-1061308ba7160b89e64adf0349a3a297137e9a8b.tar.gz
ports-1061308ba7160b89e64adf0349a3a297137e9a8b.zip
Welcome PHP 8.0 RC 2 to the ports tree
There are many greater changes including: - json is now part of core - xmlrpc is removed - More than 150 backward incompatible changes Have a look at: https://github.com/php/php-src/blob/php-8.0.0RC2/UPGRADING Reviewed by: ale, mfechner, Pascal Christen Sponsored by: PHP Update Service Differential Revision: https://reviews.freebsd.org/D26848
Notes
Notes: svn path=/head/; revision=552906
Diffstat (limited to 'textproc/php80-simplexml')
-rw-r--r--textproc/php80-simplexml/Makefile11
-rw-r--r--textproc/php80-simplexml/files/patch-config.m442
2 files changed, 53 insertions, 0 deletions
diff --git a/textproc/php80-simplexml/Makefile b/textproc/php80-simplexml/Makefile
new file mode 100644
index 000000000000..5ebb35523209
--- /dev/null
+++ b/textproc/php80-simplexml/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -simplexml
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php80-simplexml/files/patch-config.m4 b/textproc/php80-simplexml/files/patch-config.m4
new file mode 100644
index 000000000000..88638f7dccf4
--- /dev/null
+++ b/textproc/php80-simplexml/files/patch-config.m4
@@ -0,0 +1,42 @@
+--- config.m4.orig 2019-08-06 06:54:07 UTC
++++ config.m4
+@@ -4,8 +4,39 @@ PHP_ARG_ENABLE([simplexml],
+ [Disable SimpleXML support])],
+ [yes])
+
++PHP_ARG_ENABLE([pcre-dir],
++ [pcre install prefix],
++ [AS_HELP_STRING([--with-pcre-dir],
++ [SimpleXML: pcre install dir])],
++ [no],
++ [no])
++
+ if test "$PHP_SIMPLEXML" != "no"; then
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$PHP_LIBXML" = "no"; then
+ AC_MSG_ERROR([SimpleXML extension requires LIBXML extension, add --with-libxml])
+ fi