aboutsummaryrefslogtreecommitdiff
path: root/textproc/pict
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-27 13:09:48 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-27 13:09:48 +0000
commitd71a620d770d98c83e028c815e6bcc4df67a09f7 (patch)
treea47635da119bec971b42ac2a5658dc502c390db9 /textproc/pict
parentaaf8d05eb2ef4f1a10d81ab9800ac3763a5ea0b6 (diff)
downloadports-d71a620d770d98c83e028c815e6bcc4df67a09f7.tar.gz
ports-d71a620d770d98c83e028c815e6bcc4df67a09f7.zip
New port: textproc/pict
A tool for generating test cases using the PICT (Pairwise Independent Combinatorial Testing) method, based on a simple plain text format. WWW: https://github.com/Microsoft/pict PR: 231407 Submitted by: greg@unrelenting.technology
Notes
Notes: svn path=/head/; revision=491347
Diffstat (limited to 'textproc/pict')
-rw-r--r--textproc/pict/Makefile26
-rw-r--r--textproc/pict/distinfo3
-rw-r--r--textproc/pict/pkg-descr4
3 files changed, 33 insertions, 0 deletions
diff --git a/textproc/pict/Makefile b/textproc/pict/Makefile
new file mode 100644
index 000000000000..e97a3b149344
--- /dev/null
+++ b/textproc/pict/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= pict
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.7.1
+CATEGORIES= textproc devel
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Pairwise Independent Combinatorial Testing tool
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+
+USES= compiler:c++11-lang
+USE_GITHUB= yes
+GH_ACCOUNT= Microsoft
+USE_LDCONFIG= yes
+
+PLIST_FILES= bin/pict \
+ lib/libpict.so
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pict ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_LIB} ${WRKSRC}/libpict.so ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/textproc/pict/distinfo b/textproc/pict/distinfo
new file mode 100644
index 000000000000..b4e0be935cb3
--- /dev/null
+++ b/textproc/pict/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1548592395
+SHA256 (Microsoft-pict-v3.7.1_GH0.tar.gz) = 4fc7939c708f9c8d6346430b3b90f122f2cc5e341f172f94eb711b1c48f2518a
+SIZE (Microsoft-pict-v3.7.1_GH0.tar.gz) = 544722
diff --git a/textproc/pict/pkg-descr b/textproc/pict/pkg-descr
new file mode 100644
index 000000000000..33997e7a8e94
--- /dev/null
+++ b/textproc/pict/pkg-descr
@@ -0,0 +1,4 @@
+A tool for generating test cases using the PICT (Pairwise Independent
+Combinatorial Testing) method, based on a simple plain text format.
+
+WWW: https://github.com/Microsoft/pict