aboutsummaryrefslogtreecommitdiff
path: root/textproc/po4a
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2021-03-14 12:53:40 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2021-03-14 12:53:40 +0000
commitfcb640ea74c53ff9668ad95323a8beac8ee8c92b (patch)
treec97a9fc51bc46889417633533775b0ce51bcfd1f /textproc/po4a
parent930c79f2248a1299808f95b0e0f787bcb9187d61 (diff)
downloadports-fcb640ea74c53ff9668ad95323a8beac8ee8c92b.tar.gz
ports-fcb640ea74c53ff9668ad95323a8beac8ee8c92b.zip
textproc/po4a: Add patch to fix Asciidoc issue
Don't split in attributes include:: and ifeval:: lines. This fix an issue in the new FreeBSD translation workflow. Obtained from: https://github.com/mquinson/po4a/pull/298
Notes
Notes: svn path=/head/; revision=568387
Diffstat (limited to 'textproc/po4a')
-rw-r--r--textproc/po4a/Makefile1
-rw-r--r--textproc/po4a/files/patch-lib_Locale_Po4a_AsciiDoc.pm15
2 files changed, 16 insertions, 0 deletions
diff --git a/textproc/po4a/Makefile b/textproc/po4a/Makefile
index fa98494c1f7c..9fa1a89b906a 100644
--- a/textproc/po4a/Makefile
+++ b/textproc/po4a/Makefile
@@ -4,6 +4,7 @@
PORTNAME= po4a
DISTVERSIONPREFIX= v
DISTVERSION= 0.63
+PORTREVISION= 1
CATEGORIES= textproc perl5
MAINTAINER= dbaio@FreeBSD.org
diff --git a/textproc/po4a/files/patch-lib_Locale_Po4a_AsciiDoc.pm b/textproc/po4a/files/patch-lib_Locale_Po4a_AsciiDoc.pm
new file mode 100644
index 000000000000..d176b1393b4f
--- /dev/null
+++ b/textproc/po4a/files/patch-lib_Locale_Po4a_AsciiDoc.pm
@@ -0,0 +1,15 @@
+# https://github.com/mquinson/po4a/pull/298
+# Asciidoc: Don't split in attributes include:: and ifeval:: lines
+--- lib/Locale/Po4a/AsciiDoc.pm.orig 2021-02-22 16:53:34 UTC
++++ lib/Locale/Po4a/AsciiDoc.pm
+@@ -771,6 +771,10 @@ sub parse {
+ and ( defined( $self->{type} ) and ( $self->{type} eq "Table" ) ) )
+ {
+ $paragraph .= $line . "\n";
++ } elsif ( ( $macroname eq "include" || $macroname eq "ifeval" )
++ and ( $macrotype eq '::' ) )
++ {
++ $self->pushline( $line . "\n" );
+ } else {
+ if ( $macrotype eq '::' ) {
+ do_paragraph( $self, $paragraph, $wrapped_mode );