aboutsummaryrefslogtreecommitdiff
path: root/textproc/pugixml/files
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-10-10 18:28:26 +0000
committerSteve Wills <swills@FreeBSD.org>2017-10-10 18:28:26 +0000
commit93e6d6fd8d9938c8774b2a0df6a6e9da019fd4ca (patch)
tree44b935bb8155027cbf3db2a1438837e4de2c8e7e /textproc/pugixml/files
parentf88eae144c5807e56e97ecd3fa4dad3974cc02e8 (diff)
downloadports-93e6d6fd8d9938c8774b2a0df6a6e9da019fd4ca.tar.gz
ports-93e6d6fd8d9938c8774b2a0df6a6e9da019fd4ca.zip
Notes
Diffstat (limited to 'textproc/pugixml/files')
-rw-r--r--textproc/pugixml/files/patch-CMakeLists.txt62
-rw-r--r--textproc/pugixml/files/patch-scripts_CMakeLists.txt34
-rw-r--r--textproc/pugixml/files/patch-scripts_pugixml.pc.in18
3 files changed, 80 insertions, 34 deletions
diff --git a/textproc/pugixml/files/patch-CMakeLists.txt b/textproc/pugixml/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..aef338932ea7
--- /dev/null
+++ b/textproc/pugixml/files/patch-CMakeLists.txt
@@ -0,0 +1,62 @@
+--- CMakeLists.txt.orig 2016-11-27 15:48:03.000000000 -0500
++++ CMakeLists.txt 2017-09-14 18:31:07.892853000 -0400
+@@ -2,7 +2,8 @@
+
+ cmake_minimum_required(VERSION 2.6)
+
+-option(BUILD_SHARED_LIBS "Build shared instead of static library" OFF)
++option(BUILD_SHARED_LIBS "Build shared library" OFF)
++option(BUILD_STATIC_LIBS "Build static library" OFF)
+ option(BUILD_TESTS "Build tests" OFF)
+ option(BUILD_PKGCONFIG "Build in PKGCONFIG mode" OFF)
+
+@@ -38,28 +39,27 @@
+
+ if(BUILD_SHARED_LIBS)
+ add_library(pugixml SHARED ${SOURCES})
+-else()
+- add_library(pugixml STATIC ${SOURCES})
++ set_target_properties(pugixml PROPERTIES VERSION 1.8 SOVERSION 1)
++ install(TARGETS pugixml EXPORT pugixml-config
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
++if(BUILD_STATIC_LIBS)
++ add_library(pugixml_static STATIC ${SOURCES})
++ set_target_properties(pugixml_static PROPERTIES OUTPUT_NAME pugixml)
++ install(TARGETS pugixml_static
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
++endif()
+
+ # Enable C++11 long long for compilers that are capable of it
+ if(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} STRLESS 3.1 AND ";${CMAKE_CXX_COMPILE_FEATURES};" MATCHES ";cxx_long_long_type;")
+ target_compile_features(pugixml PUBLIC cxx_long_long_type)
+ endif()
+
+-set_target_properties(pugixml PROPERTIES VERSION 1.8 SOVERSION 1)
+-get_target_property(PUGIXML_VERSION_STRING pugixml VERSION)
+-
+-if(BUILD_PKGCONFIG)
+- # Install library into its own directory under LIBDIR
+- set(INSTALL_SUFFIX /pugixml-${PUGIXML_VERSION_STRING})
+-endif()
+-
+-install(TARGETS pugixml EXPORT pugixml-config
+- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}${INSTALL_SUFFIX}
+- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}${INSTALL_SUFFIX}
+- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+-install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}${INSTALL_SUFFIX})
++install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+ install(EXPORT pugixml-config DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/pugixml)
+
+ if(BUILD_PKGCONFIG)
+@@ -75,4 +75,4 @@
+ add_executable(check ${TEST_SOURCES})
+ target_link_libraries(check pugixml)
+ add_custom_command(TARGET check POST_BUILD COMMAND check WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
+-endif()
+\ No newline at end of file
++endif()
diff --git a/textproc/pugixml/files/patch-scripts_CMakeLists.txt b/textproc/pugixml/files/patch-scripts_CMakeLists.txt
deleted file mode 100644
index e91febe1245f..000000000000
--- a/textproc/pugixml/files/patch-scripts_CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
---- scripts/CMakeLists.txt.orig 2015-10-19 06:15:50.000000000 +0300
-+++ scripts/CMakeLists.txt 2016-06-20 22:08:33.133152000 +0300
-@@ -19,27 +19,19 @@
- endforeach()
- endif()
-
--if(BUILD_SHARED_LIBS)
-- add_library(pugixml SHARED ${SOURCES})
--else()
-- add_library(pugixml STATIC ${SOURCES})
--endif()
--
--# Enable C++11 long long for compilers that are capable of it
--if(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} STRLESS 3.1)
-- target_compile_features(pugixml PUBLIC cxx_long_long_type)
--endif()
-+add_library(pugixml SHARED ${SOURCES})
-+add_library(pugixml_static STATIC ${SOURCES})
-
- set_target_properties(pugixml PROPERTIES VERSION 1.7 SOVERSION 1)
-+set_target_properties(pugixml_static PROPERTIES OUTPUT_NAME pugixml)
-
--install(TARGETS pugixml EXPORT pugixml-config
-+install(TARGETS pugixml pugixml_static
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- )
-
- install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
--install(EXPORT pugixml-config DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/pugixml)
-
- if(BUILD_TESTS)
- file(GLOB TEST_SOURCES ../tests/*.cpp)
diff --git a/textproc/pugixml/files/patch-scripts_pugixml.pc.in b/textproc/pugixml/files/patch-scripts_pugixml.pc.in
new file mode 100644
index 000000000000..4dfd3637e2df
--- /dev/null
+++ b/textproc/pugixml/files/patch-scripts_pugixml.pc.in
@@ -0,0 +1,18 @@
+--- scripts/pugixml.pc.in.orig 2017-09-14 18:05:00.281262000 -0400
++++ scripts/pugixml.pc.in 2017-09-14 18:05:14.312398000 -0400
+@@ -1,11 +1,11 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=${prefix}
+-includedir=${prefix}/include/pugixml-@PUGIXML_VERSION_STRING@
+-libdir=${exec_prefix}/lib/pugixml-@PUGIXML_VERSION_STRING@
++includedir=${prefix}/include
++libdir=${exec_prefix}/lib
+
+ Name: pugixml
+ Description: Light-weight, simple and fast XML parser for C++ with XPath support.
+ URL: http://pugixml.org/
+ Version: @PUGIXML_VERSION_STRING@
+ Cflags: -I${includedir}
+-Libs: -L${libdir} -lpugixml
+\ No newline at end of file
++Libs: -L${libdir} -lpugixml