aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-agate
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-07-04 15:25:16 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-07-04 15:25:16 +0000
commita8b43f545499257fa458c4451dad55905ee10108 (patch)
tree1c96cb20964e283e0e907f3466877f2e934589b2 /textproc/py-agate
parent920d18f56cb1bb8e8afb99250b5e9c40e527bd32 (diff)
downloadports-a8b43f545499257fa458c4451dad55905ee10108.tar.gz
ports-a8b43f545499257fa458c4451dad55905ee10108.zip
agate is a Python data analysis library that is optimized for humans
instead of machines. It is an alternative to numpy and pandas that solves real-world problems with readable code. agate was previously known as journalism. WWW: http://agate.rtfd.org/
Notes
Notes: svn path=/head/; revision=418035
Diffstat (limited to 'textproc/py-agate')
-rw-r--r--textproc/py-agate/Makefile26
-rw-r--r--textproc/py-agate/distinfo3
-rw-r--r--textproc/py-agate/pkg-descr7
3 files changed, 36 insertions, 0 deletions
diff --git a/textproc/py-agate/Makefile b/textproc/py-agate/Makefile
new file mode 100644
index 000000000000..440a3d367e7e
--- /dev/null
+++ b/textproc/py-agate/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= agate
+PORTVERSION= 1.4.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Data analysis library optimized for humans
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.6.1:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}pytimeparse>=1.1.5:devel/py-pytimeparse \
+ ${PYTHON_PKGNAMEPREFIX}Babel>=2.0:devel/py-babel \
+ ${PYTHON_PKGNAMEPREFIX}parsedatetime>=2.1:devel/py-parsedatetime \
+ ${PYTHON_PKGNAMEPREFIX}isodate>=0.5.4:devel/py-isodate \
+ ${PYTHON_PKGNAMEPREFIX}awesome-slugify>=1.6.5:textproc/py-awesome-slugify
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-agate/distinfo b/textproc/py-agate/distinfo
new file mode 100644
index 000000000000..acdf9bd1e39a
--- /dev/null
+++ b/textproc/py-agate/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1467645785
+SHA256 (agate-1.4.0.tar.gz) = 4436fca90177886e7747ce0a2dc293c3a49d4152baead4784c8da80861085eaf
+SIZE (agate-1.4.0.tar.gz) = 47345
diff --git a/textproc/py-agate/pkg-descr b/textproc/py-agate/pkg-descr
new file mode 100644
index 000000000000..b107f41d8bd0
--- /dev/null
+++ b/textproc/py-agate/pkg-descr
@@ -0,0 +1,7 @@
+agate is a Python data analysis library that is optimized for humans
+instead of machines. It is an alternative to numpy and pandas that
+solves real-world problems with readable code.
+
+agate was previously known as journalism.
+
+WWW: http://agate.rtfd.org/