aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-bracex
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2021-02-27 12:08:41 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2021-02-27 12:08:41 +0000
commit42001a361e55799fd6fb18fd5f75358a1428a343 (patch)
treef19f02cdb284b008f056dc43768ee0b337d380ca /textproc/py-bracex
parent53e4fa7d5b1127952fc57b4f2b0d5326e7ebe266 (diff)
downloadports-42001a361e55799fd6fb18fd5f75358a1428a343.tar.gz
ports-42001a361e55799fd6fb18fd5f75358a1428a343.zip
Bracex is a brace expanding library (a la Bash) for Python. Brace
expanding is used to generate arbitrary strings. WWW: https://pypi.org/project/bracex/
Notes
Notes: svn path=/head/; revision=566694
Diffstat (limited to 'textproc/py-bracex')
-rw-r--r--textproc/py-bracex/Makefile27
-rw-r--r--textproc/py-bracex/distinfo3
-rw-r--r--textproc/py-bracex/pkg-descr4
3 files changed, 34 insertions, 0 deletions
diff --git a/textproc/py-bracex/Makefile b/textproc/py-bracex/Makefile
new file mode 100644
index 000000000000..ca275ee6bc97
--- /dev/null
+++ b/textproc/py-bracex/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= bracex
+PORTVERSION= 2.1.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Brace expansion
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coverage>0:devel/py-coverage@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
+
+.include <bsd.port.mk>
diff --git a/textproc/py-bracex/distinfo b/textproc/py-bracex/distinfo
new file mode 100644
index 000000000000..d66dd1c41448
--- /dev/null
+++ b/textproc/py-bracex/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614426133
+SHA256 (bracex-2.1.1.tar.gz) = 01f715cd0ed7a622ec8b32322e715813f7574de531f09b70f6f3b2c10f682425
+SIZE (bracex-2.1.1.tar.gz) = 26628
diff --git a/textproc/py-bracex/pkg-descr b/textproc/py-bracex/pkg-descr
new file mode 100644
index 000000000000..780959381e65
--- /dev/null
+++ b/textproc/py-bracex/pkg-descr
@@ -0,0 +1,4 @@
+Bracex is a brace expanding library (a la Bash) for Python. Brace
+expanding is used to generate arbitrary strings.
+
+WWW: https://pypi.org/project/bracex/