aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-docutils
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2018-05-22 05:29:07 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2018-05-22 05:29:07 +0000
commit078458911a7c8f257639fcf81403f87da364f01a (patch)
tree45f5b013ce1b503c315c4c473f0d36cf7ae6029f /textproc/py-docutils
parent1efba9ebdd13e5555ebfa0f5df1404f6663c6cfe (diff)
downloadports-078458911a7c8f257639fcf81403f87da364f01a.tar.gz
ports-078458911a7c8f257639fcf81403f87da364f01a.zip
textproc/py-docutils: Fix/improve console scripts packaging
Remove custom script symlink/packaging routine (and pkg-plist) that adds versions without .py filename suffix, in favour of what upstream provides by default. The manually maintained script list in the port was incomplete, so not all scripts were processed, producing an inconsistent experience (if not POLA violation) for users, and proves the mechanism itself is difficult to keep up-to-date and accurate. Additionally, all upstream documentation refers to these tools by their suffixed names. While I'm here: - Pet potlint (USES/USE_* order) - Add test target to make future QA easier/more thorough. Approved by: koobs (python, maintainer)
Notes
Notes: svn path=/head/; revision=470596
Diffstat (limited to 'textproc/py-docutils')
-rw-r--r--textproc/py-docutils/Makefile25
-rw-r--r--textproc/py-docutils/pkg-plist10
2 files changed, 14 insertions, 21 deletions
diff --git a/textproc/py-docutils/Makefile b/textproc/py-docutils/Makefile
index ece521a73cff..1aa44ac1add5 100644
--- a/textproc/py-docutils/Makefile
+++ b/textproc/py-docutils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= docutils
PORTVERSION= 0.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,19 +17,22 @@ LICENSE_COMB= multi
PORTSCOUT= limit:^[0-9\.]*$$
NO_ARCH= yes
-USE_PYTHON= autoplist concurrent distutils
+
USES= python
+USE_PYTHON= autoplist concurrent distutils
OPTIONS_DEFINE= PYGMENTS
-PYGMENTS_DESC= Syntax highlighting
-PYGMENTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments@${FLAVOR}
-SCRIPTS= rst2html rst2latex rst2man rst2odt rst2odt_prepstyles \
- rst2pseudoxml rst2s5 rst2xetex rst2xml rstpep2html
+PYGMENTS_DESC= Syntax highlighting
+PYGMENTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments@${PY_FLAVOR}
+
+.include <bsd.port.pre.mk>
-post-install:
-.for script in ${SCRIPTS}
- ${LN} -s ${script}.py-${PYTHON_VER} ${STAGEDIR}${PREFIX}/bin/${script}
-.endfor
+do-test:
+.if ${PYTHON_VER} < 3
+ @cd ${WRKSRC}/test && ${PYTHON_CMD} alltests.py
+.else
+ @cd ${WRKSRC}/test3 && ${PYTHON_CMD} alltests.py
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/py-docutils/pkg-plist b/textproc/py-docutils/pkg-plist
deleted file mode 100644
index 7d1eed03382e..000000000000
--- a/textproc/py-docutils/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-bin/rst2html
-bin/rst2latex
-bin/rst2man
-bin/rst2odt
-bin/rst2odt_prepstyles
-bin/rst2pseudoxml
-bin/rst2s5
-bin/rst2xetex
-bin/rst2xml
-bin/rstpep2html