aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-elasticsearch6
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-11-13 23:47:48 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-11-13 23:47:48 +0000
commit6ad51591d863a12538fac39d7ac361d0bfeb46f6 (patch)
tree94d1a95aa5888ca39b1bb52a21de719df862b575 /textproc/py-elasticsearch6
parent2a767ba54814e01f17fbcdb1d796c6f367672c1f (diff)
downloadports-6ad51591d863a12538fac39d7ac361d0bfeb46f6.tar.gz
ports-6ad51591d863a12538fac39d7ac361d0bfeb46f6.zip
Fix build with py-urllib 1.25+
- Bump PORTREVISION for package change PR: 241874 Submitted by: kai Backport from: https://github.com/elastic/elasticsearch-py/commit/4c531c5cdbd5ba8b59be16c2fa15d5cf81d0a92f
Notes
Notes: svn path=/head/; revision=517541
Diffstat (limited to 'textproc/py-elasticsearch6')
-rw-r--r--textproc/py-elasticsearch6/Makefile1
-rw-r--r--textproc/py-elasticsearch6/files/patch-elasticsearch-connection-http_urllib3.py12
2 files changed, 13 insertions, 0 deletions
diff --git a/textproc/py-elasticsearch6/Makefile b/textproc/py-elasticsearch6/Makefile
index 64c6b27f2b2a..1ef44da90626 100644
--- a/textproc/py-elasticsearch6/Makefile
+++ b/textproc/py-elasticsearch6/Makefile
@@ -3,6 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 6.4.0
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/textproc/py-elasticsearch6/files/patch-elasticsearch-connection-http_urllib3.py b/textproc/py-elasticsearch6/files/patch-elasticsearch-connection-http_urllib3.py
new file mode 100644
index 000000000000..a688f1019de2
--- /dev/null
+++ b/textproc/py-elasticsearch6/files/patch-elasticsearch-connection-http_urllib3.py
@@ -0,0 +1,12 @@
+Backport from: https://github.com/elastic/elasticsearch-py/commit/4c531c5cdbd5ba8b59be16c2fa15d5cf81d0a92f
+
+--- elasticsearch/connection/http_urllib3.py.orig 2019-05-28 17:59:13 UTC
++++ elasticsearch/connection/http_urllib3.py
+@@ -170,6 +170,7 @@ class Urllib3HttpConnection(Connection):
+ }
+ )
+ else:
++ kw["cert_reqs"] = "CERT_NONE"
+ warnings.warn(
+ "Connecting to %s using SSL with verify_certs=False is insecure."
+ % host