aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-elementpath
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2020-10-16 02:50:07 +0000
committerWen Heping <wen@FreeBSD.org>2020-10-16 02:50:07 +0000
commite36f9cd67079934baf8ad6ec3ad8baa2db8d4917 (patch)
treef75cea484bf7f1e9a4c81d73c924029fa2268c3a /textproc/py-elementpath
parentd7fe8afa2ddf36e24361e9c05100e3a060019192 (diff)
downloadports-e36f9cd67079934baf8ad6ec3ad8baa2db8d4917.tar.gz
ports-e36f9cd67079934baf8ad6ec3ad8baa2db8d4917.zip
The proposal of this package is to provide XPath 1.0 and 2.0 selectors for
Python's ElementTree XML data structures, both for the standard ElementTree library and for the lxml.etree library. For lxml.etree this package can be useful for providing XPath 2.0 selectors, because lxml.etree already has it's own implementation of XPath 1.0. WWW: https://github.com/sissaschool/elementpath
Notes
Notes: svn path=/head/; revision=552488
Diffstat (limited to 'textproc/py-elementpath')
-rw-r--r--textproc/py-elementpath/Makefile26
-rw-r--r--textproc/py-elementpath/distinfo3
-rw-r--r--textproc/py-elementpath/pkg-descr8
3 files changed, 37 insertions, 0 deletions
diff --git a/textproc/py-elementpath/Makefile b/textproc/py-elementpath/Makefile
new file mode 100644
index 000000000000..bb88ce60baf3
--- /dev/null
+++ b/textproc/py-elementpath/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= elementpath
+DISTVERSION= 2.0.3
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= XPath 1.0/2.0 parsers and selectors for ElementTree and lxml
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils concurrent autoplist
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/textproc/py-elementpath/distinfo b/textproc/py-elementpath/distinfo
new file mode 100644
index 000000000000..f9f74e9abce2
--- /dev/null
+++ b/textproc/py-elementpath/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1602840940
+SHA256 (elementpath-2.0.3.tar.gz) = 1f652f515866f2a9bdf96f118cd3f9d328af213451c0a88c34d061eec729bdcf
+SIZE (elementpath-2.0.3.tar.gz) = 191499
diff --git a/textproc/py-elementpath/pkg-descr b/textproc/py-elementpath/pkg-descr
new file mode 100644
index 000000000000..7dbc8fcb3603
--- /dev/null
+++ b/textproc/py-elementpath/pkg-descr
@@ -0,0 +1,8 @@
+The proposal of this package is to provide XPath 1.0 and 2.0 selectors for
+Python's ElementTree XML data structures, both for the standard ElementTree
+library and for the lxml.etree library.
+
+For lxml.etree this package can be useful for providing XPath 2.0 selectors,
+because lxml.etree already has it's own implementation of XPath 1.0.
+
+WWW: https://github.com/sissaschool/elementpath