aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-empy
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 09:33:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 09:33:47 +0000
commit1f279f37acca365808f91cea4f2b962431727e26 (patch)
treedcd3d557509a894691538c8205a10e4e02acc9ae /textproc/py-empy
parenta74ad217f2bc3d91839f5f81cc634e4ca9ceade1 (diff)
downloadports-1f279f37acca365808f91cea4f2b962431727e26.tar.gz
ports-1f279f37acca365808f91cea4f2b962431727e26.zip
EmPy is a system for embedding Python expressions and statements in template
text; it takes an EmPy source file, processes it, and produces output. This is accomplished via expansions, which are special signals to the EmPy system and are set off by a special prefix (by default the at sign, @). EmPy can expand arbitrary Python expressions and statements in this way, as well as a variety of special forms. Textual data not explicitly delimited in this way is sent unaffected to the output, allowing Python to be used in effect as a markup language. Also supported are callbacks via hooks, recording and playback via diversions, and dynamic, chainable filters. The system is highly configurable via command line options and embedded commands. PR: ports/83308 Submitted by: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=139045
Diffstat (limited to 'textproc/py-empy')
-rw-r--r--textproc/py-empy/Makefile21
-rw-r--r--textproc/py-empy/distinfo2
-rw-r--r--textproc/py-empy/pkg-descr12
-rw-r--r--textproc/py-empy/pkg-plist3
4 files changed, 38 insertions, 0 deletions
diff --git a/textproc/py-empy/Makefile b/textproc/py-empy/Makefile
new file mode 100644
index 000000000000..90c8e3bd3777
--- /dev/null
+++ b/textproc/py-empy/Makefile
@@ -0,0 +1,21 @@
+# ex:ts=8
+# Ports collection makefile for: py-empy
+# Date created: Jul 12, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= empy
+PORTVERSION= 3.3
+CATEGORIES= textproc python
+MASTER_SITES= http://www.alcyone.com/software/empy/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A powerful and robust templating system for Python
+
+USE_PYTHON= 1.5+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-empy/distinfo b/textproc/py-empy/distinfo
new file mode 100644
index 000000000000..599db6349b33
--- /dev/null
+++ b/textproc/py-empy/distinfo
@@ -0,0 +1,2 @@
+MD5 (empy-3.3.tar.gz) = e7b518a6fc4fd28fef87726cdb003118
+SIZE (empy-3.3.tar.gz) = 137144
diff --git a/textproc/py-empy/pkg-descr b/textproc/py-empy/pkg-descr
new file mode 100644
index 000000000000..94c90acc3303
--- /dev/null
+++ b/textproc/py-empy/pkg-descr
@@ -0,0 +1,12 @@
+EmPy is a system for embedding Python expressions and statements in template
+text; it takes an EmPy source file, processes it, and produces output. This
+is accomplished via expansions, which are special signals to the EmPy system
+and are set off by a special prefix (by default the at sign, @). EmPy can
+expand arbitrary Python expressions and statements in this way, as well as a
+variety of special forms. Textual data not explicitly delimited in this way
+is sent unaffected to the output, allowing Python to be used in effect as a
+markup language. Also supported are callbacks via hooks, recording and
+playback via diversions, and dynamic, chainable filters. The system is highly
+configurable via command line options and embedded commands.
+
+WWW: http://www.alcyone.com/software/empy/
diff --git a/textproc/py-empy/pkg-plist b/textproc/py-empy/pkg-plist
new file mode 100644
index 000000000000..c1b66dca2a1d
--- /dev/null
+++ b/textproc/py-empy/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/em.py
+%%PYTHON_SITELIBDIR%%/em.pyc
+%%PYTHON_SITELIBDIR%%/em.pyo