aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-ftfy
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-23 04:21:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-23 04:21:04 +0000
commit174cff2e7c3995a996f821c232cbe253375652dd (patch)
tree89aa0094a392ff970e67893b36d415e97f45457a /textproc/py-ftfy
parent561dc7af004e45a620020287b4a6b0c44da7fad1 (diff)
downloadports-174cff2e7c3995a996f821c232cbe253375652dd.tar.gz
ports-174cff2e7c3995a996f821c232cbe253375652dd.zip
Add py-ftfy 5.6
ftfy: fixes text for you ftfy fixes Unicode that's broken in various ways. The goal of ftfy is to take in bad Unicode and output good Unicode, for use in your Unicode-aware code. This is different from taking in non-Unicode and outputting Unicode, which is not a goal of ftfy. It also isn't designed to protect you from having to write Unicode-aware code. ftfy helps those who help themselves. Of course you're better off if your input is decoded properly and has no glitches. But you often don't have any control over your input; it's someone else's mistake, but it's your problem now. ftfy will do everything it can to fix the problem. WWW: https://github.com/LuminosoInsight/python-ftfy
Notes
Notes: svn path=/head/; revision=523869
Diffstat (limited to 'textproc/py-ftfy')
-rw-r--r--textproc/py-ftfy/Makefile24
-rw-r--r--textproc/py-ftfy/distinfo3
-rw-r--r--textproc/py-ftfy/pkg-descr17
3 files changed, 44 insertions, 0 deletions
diff --git a/textproc/py-ftfy/Makefile b/textproc/py-ftfy/Makefile
new file mode 100644
index 000000000000..a6fb421b3f7d
--- /dev/null
+++ b/textproc/py-ftfy/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ftfy
+PORTVERSION= 5.6
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fix some problems with Unicode text after the fact
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wcwidth>=0:devel/py-wcwidth@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.4+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-ftfy/distinfo b/textproc/py-ftfy/distinfo
new file mode 100644
index 000000000000..781c0ce612c7
--- /dev/null
+++ b/textproc/py-ftfy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579684128
+SHA256 (ftfy-5.6.tar.gz) = 6d7509c45e602dec890f0f6ee0623a8b5f50ec1188ac7ab9535e18e572c99bcc
+SIZE (ftfy-5.6.tar.gz) = 58808
diff --git a/textproc/py-ftfy/pkg-descr b/textproc/py-ftfy/pkg-descr
new file mode 100644
index 000000000000..71cd2d6cba66
--- /dev/null
+++ b/textproc/py-ftfy/pkg-descr
@@ -0,0 +1,17 @@
+ftfy: fixes text for you
+
+ftfy fixes Unicode that's broken in various ways.
+
+The goal of ftfy is to take in bad Unicode and output good Unicode, for use in
+your Unicode-aware code. This is different from taking in non-Unicode and
+outputting Unicode, which is not a goal of ftfy. It also isn't designed to
+protect you from having to write Unicode-aware code. ftfy helps those who help
+themselves.
+
+Of course you're better off if your input is decoded properly and has no
+glitches. But you often don't have any control over your input; it's someone
+else's mistake, but it's your problem now.
+
+ftfy will do everything it can to fix the problem.
+
+WWW: https://github.com/LuminosoInsight/python-ftfy