aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-markdown2
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-17 09:40:21 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-17 09:40:21 +0000
commit118d91a2647254ccd594f1671b7e5929bdf216c6 (patch)
treeab736a111e4d71c98c1c06bb3d01afa1b82aaceb /textproc/py-markdown2
parent8063cb761e01ac790e436637f70abd9908450034 (diff)
downloadports-118d91a2647254ccd594f1671b7e5929bdf216c6.tar.gz
ports-118d91a2647254ccd594f1671b7e5929bdf216c6.zip
Markdown is two things: (1) a plain text formatting syntax; and (2) a
software tool that converts the plain text formatting to (X)HTML. The formatting syntax is designed to be easy and intuitive for web authors and resembles typical email formatting conventions. The resultant (X)HTML is structurally valid. WWW: http://www.freewisdom.org/projects/python-markdown PR: ports/105992 Submitted by: Graham Todd <gtodd at bellanet.org>
Notes
Notes: svn path=/head/; revision=180001
Diffstat (limited to 'textproc/py-markdown2')
-rw-r--r--textproc/py-markdown2/Makefile23
-rw-r--r--textproc/py-markdown2/distinfo3
-rw-r--r--textproc/py-markdown2/pkg-descr7
-rw-r--r--textproc/py-markdown2/pkg-plist3
4 files changed, 36 insertions, 0 deletions
diff --git a/textproc/py-markdown2/Makefile b/textproc/py-markdown2/Makefile
new file mode 100644
index 000000000000..715f54b96bf2
--- /dev/null
+++ b/textproc/py-markdown2/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-markdown
+# Date created: 28 November 2006
+# Whom: Graham Todd <gtodd@bellanet.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= markdown
+PORTVERSION= 1.6
+CATEGORIES= textproc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= python-markdown
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION}a
+
+MAINTAINER= alexbl@FreeBSD.org
+COMMENT= Text markup to HTML conversion engine for Python
+
+USE_ZIP= yes
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-markdown2/distinfo b/textproc/py-markdown2/distinfo
new file mode 100644
index 000000000000..481ae00cd494
--- /dev/null
+++ b/textproc/py-markdown2/distinfo
@@ -0,0 +1,3 @@
+MD5 (markdown-1.6a.zip) = 21b5882f76264f84b0c6edf54ca38d2d
+SHA256 (markdown-1.6a.zip) = fbf349b8d4e4594eea50c9312754370c69d8df5ae7af4b6f5d857d17f871217b
+SIZE (markdown-1.6a.zip) = 25236
diff --git a/textproc/py-markdown2/pkg-descr b/textproc/py-markdown2/pkg-descr
new file mode 100644
index 000000000000..473b80fcdcb4
--- /dev/null
+++ b/textproc/py-markdown2/pkg-descr
@@ -0,0 +1,7 @@
+Markdown is two things: (1) a plain text formatting syntax; and (2) a
+software tool that converts the plain text formatting to (X)HTML. The
+formatting syntax is designed to be easy and intuitive for web authors
+and resembles typical email formatting conventions. The resultant
+(X)HTML is structurally valid.
+
+WWW: http://www.freewisdom.org/projects/python-markdown
diff --git a/textproc/py-markdown2/pkg-plist b/textproc/py-markdown2/pkg-plist
new file mode 100644
index 000000000000..28c19b0a3bba
--- /dev/null
+++ b/textproc/py-markdown2/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/markdown.py
+%%PYTHON_SITELIBDIR%%/markdown.pyc
+%%PYTHON_SITELIBDIR%%/markdown.pyo