aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-normality
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2018-07-28 12:22:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2018-07-28 12:22:52 +0000
commitc434e1fb8bc883ce6c8e0ad639aa19575d0ff4dd (patch)
tree6c64167a207ffc4b3f6cc2f5574a8e1bbee042a0 /textproc/py-normality
parent9884dde02d12ddc4ff8afbb97f50e87d97b4d445 (diff)
downloadports-c434e1fb8bc883ce6c8e0ad639aa19575d0ff4dd.tar.gz
ports-c434e1fb8bc883ce6c8e0ad639aa19575d0ff4dd.zip
Normality is a Python micro-package that contains a small set of text
normalization functions for easier re-use. These functions accept a snippet of unicode or utf-8 encoded text and remove various classes of characters, such as diacritics, punctuation etc. This is useful as a preparation to further text analysis. WWW: https://github.com/pudo/normality PR: 229527 Submitted by: freebsd_ports@k-worx.org Sponsored by: iXsystems Inc.
Notes
Notes: svn path=/head/; revision=475545
Diffstat (limited to 'textproc/py-normality')
-rw-r--r--textproc/py-normality/Makefile28
-rw-r--r--textproc/py-normality/distinfo3
-rw-r--r--textproc/py-normality/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/textproc/py-normality/Makefile b/textproc/py-normality/Makefile
new file mode 100644
index 000000000000..f8f8dc34707a
--- /dev/null
+++ b/textproc/py-normality/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= normality
+DISTVERSION= 0.6.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Micro-library to normalize text strings
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}banal>=0:devel/py-banal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+post-extract:
+ # Prevents that the tests directory will be installed into site-packages
+ @(cd ${WRKSRC} && ${MV} tests test)
+
+.include <bsd.port.mk>
diff --git a/textproc/py-normality/distinfo b/textproc/py-normality/distinfo
new file mode 100644
index 000000000000..0b90dc0a722f
--- /dev/null
+++ b/textproc/py-normality/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530200443
+SHA256 (normality-0.6.1.tar.gz) = 739c1b40cfaefabdf537972f0284df5ce0ddb371f9475b764f478cb25bc1c4be
+SIZE (normality-0.6.1.tar.gz) = 7887
diff --git a/textproc/py-normality/pkg-descr b/textproc/py-normality/pkg-descr
new file mode 100644
index 000000000000..5fccf5b551ac
--- /dev/null
+++ b/textproc/py-normality/pkg-descr
@@ -0,0 +1,7 @@
+Normality is a Python micro-package that contains a small set of text
+normalization functions for easier re-use. These functions accept a snippet of
+unicode or utf-8 encoded text and remove various classes of characters, such as
+diacritics, punctuation etc. This is useful as a preparation to further text
+analysis.
+
+WWW: https://github.com/pudo/normality