aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-numpydoc
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-05-11 23:51:58 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-05-11 23:51:58 +0000
commit75a5f7f0762c1039d83da77f699eed5f26998731 (patch)
treed08289c54ff9db139f0a17e3129c69e9b0ae39b1 /textproc/py-numpydoc
parent91dd9e62375f38dcfa9e2214347d9837b18c8810 (diff)
downloadports-75a5f7f0762c1039d83da77f699eed5f26998731.tar.gz
ports-75a5f7f0762c1039d83da77f699eed5f26998731.zip
Update Sphinx
- Repocopy textproc/py-sphinx to textproc/py-sphinx18 Update it to 1.8.5 (latest version from 1.8.X). This version supports Python 2 and 3. Add test target. - textproc/py-sphinx: Update to 3.0.2 Python 3 only (3.5+). Add test target. - Mk/Uses/python.mk: Add PY_SPHINX Shared macro to use with flavors and not break ports with USES=python (all versions). Python >=3.5 --> textproc/py-sphinx (v3.0.2) Python < 3.5 --> textproc/py-sphinx18 (v1.8.5) All ports that uses sphinx were changed to use the new variable ${PY_SPHINX} in the dependency line, exceptions: * Ports that fails to build with sphinx 3.0.2 because of code. They are pointing to textproc/py-sphinx18 directly. There aren't many ports. * Ports that doesn't know Python flavors. - Add several patches to fix Sphinx consumers The most common issues are related with pkg-plist, the output files from Sphinx changes between versions, keep this dynamically is the better approach. This will save time in future sphinx updates. PR: 245629 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=534966
Diffstat (limited to 'textproc/py-numpydoc')
-rw-r--r--textproc/py-numpydoc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/textproc/py-numpydoc/Makefile b/textproc/py-numpydoc/Makefile
index 2edc716bd28e..f1a4e7518ac7 100644
--- a/textproc/py-numpydoc/Makefile
+++ b/textproc/py-numpydoc/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.3:devel/py-Jinja2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sphinx>=1.6.5:textproc/py-sphinx@${PY_FLAVOR}
+ ${PY_SPHINX}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
USES= python