aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-ocrmypdf
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-07-15 10:14:38 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-07-15 10:14:38 +0000
commit299db5ac3dfca8bc75898960067d744b9e607533 (patch)
tree0dd504c9b74e3fcba04632c1fc60e312fb127f67 /textproc/py-ocrmypdf
parentfcc278aeea242bfc0cf9e5349c68ae261a8f3c61 (diff)
downloadports-299db5ac3dfca8bc75898960067d744b9e607533.tar.gz
ports-299db5ac3dfca8bc75898960067d744b9e607533.zip
textproc/py-ocrmypdf: Use defined locale in whole build process
* Set the locale globally for {CONFIGURE,MAKE}_ENV so that the locale doesn't need to be set explicitly for the do-test target. * Use ECHO_CMD instead of ECHO as the latter one is already defined in /usr/share/mk/sys.mk, which can either be "echo" or "true" if the make flag -s is given. Suggested by: sunpoet
Notes
Notes: svn path=/head/; revision=506655
Diffstat (limited to 'textproc/py-ocrmypdf')
-rw-r--r--textproc/py-ocrmypdf/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/textproc/py-ocrmypdf/Makefile b/textproc/py-ocrmypdf/Makefile
index 9ba912e73eff..33896980d5e5 100644
--- a/textproc/py-ocrmypdf/Makefile
+++ b/textproc/py-ocrmypdf/Makefile
@@ -52,7 +52,7 @@ SHEBANG_FILES= src/ocrmypdf/__main__.py \
tests/spoof/gs_raster_failure.py \
tests/spoof/tesseract_crash.py
-MAKE_ENV= LC_ALL=en_US.UTF-8
+USE_LOCALE= en_US.UTF-8
NO_ARCH= yes
@@ -63,14 +63,14 @@ NO_ARCH= yes
# See here for a related issue from another port (audio/py-sounddevice):
# https://github.com/spatialaudio/python-sounddevice/issues/116
post-install:
- ${ECHO} "${PYTHONPREFIX_SITELIBDIR}/ocrmypdf/lib/__pycache__/_leptonica.cpython-${PYTHON_SUFFIX}.opt-1.pyc" >> ${_PYTHONPKGLIST}
- ${ECHO} "${PYTHONPREFIX_SITELIBDIR}/ocrmypdf/lib/__pycache__/_leptonica.cpython-${PYTHON_SUFFIX}.pyc" >> ${_PYTHONPKGLIST}
- ${ECHO} "${PYTHONPREFIX_SITELIBDIR}/ocrmypdf/lib/_leptonica.py" >> ${_PYTHONPKGLIST}
+ ${ECHO_CMD} "${PYTHONPREFIX_SITELIBDIR}/ocrmypdf/lib/__pycache__/_leptonica.cpython-${PYTHON_SUFFIX}.opt-1.pyc" >> ${_PYTHONPKGLIST}
+ ${ECHO_CMD} "${PYTHONPREFIX_SITELIBDIR}/ocrmypdf/lib/__pycache__/_leptonica.cpython-${PYTHON_SUFFIX}.pyc" >> ${_PYTHONPKGLIST}
+ ${ECHO_CMD} "${PYTHONPREFIX_SITELIBDIR}/ocrmypdf/lib/_leptonica.py" >> ${_PYTHONPKGLIST}
# Some unittests use a custom marker (= "slow") which is also used here, so
# that the overall test doesn't finish with a warning.
do-test:
- @cd ${WRKSRC} && ${SETENV} LC_ALL=en_US.UTF-8 ${PYTHON_CMD} -m pytest -rs -v \
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} -m pytest -rs -v \
-n ${MAKE_JOBS_NUMBER} -o 'markers=slow' -o 'addopts="--runslow"' -k ' \
not test_dev_null and \
not test_mono_not_inverted'