aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-pdfminer.six
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2018-07-28 12:05:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2018-07-28 12:05:28 +0000
commit69924d8cc2b927af929ccebd3219ef253e7805a7 (patch)
treefd618375bc44263856db7c3b7ac942631304ee78 /textproc/py-pdfminer.six
parent3f1d00491d46b15dd42a3353b8c1100197f05742 (diff)
downloadports-69924d8cc2b927af929ccebd3219ef253e7805a7.tar.gz
ports-69924d8cc2b927af929ccebd3219ef253e7805a7.zip
PDFMiner.six is a fork of PDFMiner using six for Python 2 + 3 compatibility.
PDFMiner is a tool for extracting information from PDF documents. Unlike other PDF-related tools, it focuses entirely on getting and analyzing text data. PDFMiner allows one to obtain the exact location of text in a page, as well as other information such as fonts or lines. It includes a PDF converter that can transform PDF files into other text formats (such as HTML). It has an extensible PDF parser that can be used for other purposes than text analysis. Features: - Parse, analyze, and convert PDF documents. - PDF-1.7 specification support. (well, almost) - CJK languages and vertical writing scripts support. - Various font types (Type1, TrueType, Type3, and CID) support. - Basic encryption (RC4) support. - Outline (TOC) extraction. - Tagged contents extraction. - Automatic layout analysis. WWW: https://github.com/pdfminer/pdfminer.six PR: 229447 Submitted by: freebsd_ports@k-worx.org Sponsored by: iXsystems Inc.
Notes
Notes: svn path=/head/; revision=475531
Diffstat (limited to 'textproc/py-pdfminer.six')
-rw-r--r--textproc/py-pdfminer.six/Makefile32
-rw-r--r--textproc/py-pdfminer.six/distinfo3
-rw-r--r--textproc/py-pdfminer.six/pkg-descr22
3 files changed, 57 insertions, 0 deletions
diff --git a/textproc/py-pdfminer.six/Makefile b/textproc/py-pdfminer.six/Makefile
new file mode 100644
index 000000000000..2b779bf64de5
--- /dev/null
+++ b/textproc/py-pdfminer.six/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= pdfminer.six
+PORTVERSION= 20170720
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= PDF parser and analyzer
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycryptodome>=0:security/py-pycryptodome@${PY_FLAVOR}
+
+USES= python shebangfix dos2unix
+USE_PYTHON= distutils concurrent autoplist
+SHEBANG_FILES= tools/dumppdf.py tools/pdf2txt.py tools/latin2ascii.py
+DOS2UNIXGLOB= *.py
+
+CONFLICTS_INSTALL= py??-pdfminer-* py??-pdfminer3k-*
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 3000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/py-pdfminer.six/distinfo b/textproc/py-pdfminer.six/distinfo
new file mode 100644
index 000000000000..f1ab6eeda2fc
--- /dev/null
+++ b/textproc/py-pdfminer.six/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530196324
+SHA256 (pdfminer.six-20170720.tar.gz) = a37c6348a8d903cf5f7d50346b0569a7c669afdb625b1ee25056f01fb82bd3e0
+SIZE (pdfminer.six-20170720.tar.gz) = 11992116
diff --git a/textproc/py-pdfminer.six/pkg-descr b/textproc/py-pdfminer.six/pkg-descr
new file mode 100644
index 000000000000..5061956d85d0
--- /dev/null
+++ b/textproc/py-pdfminer.six/pkg-descr
@@ -0,0 +1,22 @@
+PDFMiner.six is a fork of PDFMiner using six for Python 2 + 3 compatibility.
+
+PDFMiner is a tool for extracting information from PDF documents. Unlike other
+PDF-related tools, it focuses entirely on getting and analyzing text data.
+
+PDFMiner allows one to obtain the exact location of text in a page, as well as
+other information such as fonts or lines. It includes a PDF converter that can
+transform PDF files into other text formats (such as HTML). It has an extensible
+PDF parser that can be used for other purposes than text analysis.
+
+Features:
+
+- Parse, analyze, and convert PDF documents.
+- PDF-1.7 specification support. (well, almost)
+- CJK languages and vertical writing scripts support.
+- Various font types (Type1, TrueType, Type3, and CID) support.
+- Basic encryption (RC4) support.
+- Outline (TOC) extraction.
+- Tagged contents extraction.
+- Automatic layout analysis.
+
+WWW: https://github.com/pdfminer/pdfminer.six