aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-python-slugify/Makefile
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2019-10-03 21:52:19 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2019-10-03 21:52:19 +0000
commit85655d065adcaa272b7a65193a58adc94298d74e (patch)
tree6dfb5c62fe2d827c27e320619db45daf18ffb37d /textproc/py-python-slugify/Makefile
parent810a97ea7655231dec228a9b65032518558ca4a8 (diff)
downloadports-85655d065adcaa272b7a65193a58adc94298d74e.tar.gz
ports-85655d065adcaa272b7a65193a58adc94298d74e.zip
Notes
Diffstat (limited to 'textproc/py-python-slugify/Makefile')
-rw-r--r--textproc/py-python-slugify/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/textproc/py-python-slugify/Makefile b/textproc/py-python-slugify/Makefile
index 01382beb56b3..195dc84d6e92 100644
--- a/textproc/py-python-slugify/Makefile
+++ b/textproc/py-python-slugify/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= python-slugify
-PORTVERSION= 3.0.3
+PORTVERSION= 3.0.4
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +11,11 @@ COMMENT= Slugify application that handles unicode
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}unidecode>=0.04.16:converters/py-unidecode@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}text-unidecode>=1.3:converters/py-text-unidecode@${PY_FLAVOR}
+
+### Can alternatively require:
+### ${PYTHON_PKGNAMEPREFIX}unidecode>=1.1.1:converters/py-unidecode@${PY_FLAVOR}
+### but text-unidecode is preferred upstream.
USES= python
USE_PYTHON= autoplist distutils