aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-python-xmp-toolkit
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-07-11 16:04:59 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-07-11 16:04:59 +0000
commitd513ecb52c5ddaee73307c27ff61b84bb104d7ce (patch)
tree9066de47d39bf0a8158158d6ee0779b931326fd0 /textproc/py-python-xmp-toolkit
parentceb84be996570b4f5675b3e567adbce5fd4321b5 (diff)
downloadports-d513ecb52c5ddaee73307c27ff61b84bb104d7ce.tar.gz
ports-d513ecb52c5ddaee73307c27ff61b84bb104d7ce.zip
New port: textproc/py-python-xmp-toolkit
Python XMP Toolkit is a library for working with XMP (= Extensible Metadata Platform) metadata, as well as reading/writing XMP metadata stored in many different file formats. Python XMP Toolkit is wrapping Exempi (using ctypes), a C/C++ XMP library based on Adobe XMP Toolkit, ensuring that future updates to the XMP standard are easily incorporated into the library with a minimum amount of work. Python XMP Toolkit has been developed by: * ESA/Hubble - European Space Agency * ESO - European Southern Observatory * CRS4 - Centre for Advanced Studies, Research and Development in Sardinia WWW: https://github.com/python-xmp-toolkit/python-xmp-toolkit
Notes
Notes: svn path=/head/; revision=506411
Diffstat (limited to 'textproc/py-python-xmp-toolkit')
-rw-r--r--textproc/py-python-xmp-toolkit/Makefile28
-rw-r--r--textproc/py-python-xmp-toolkit/distinfo3
-rw-r--r--textproc/py-python-xmp-toolkit/pkg-descr14
3 files changed, 45 insertions, 0 deletions
diff --git a/textproc/py-python-xmp-toolkit/Makefile b/textproc/py-python-xmp-toolkit/Makefile
new file mode 100644
index 000000000000..94f04171acfe
--- /dev/null
+++ b/textproc/py-python-xmp-toolkit/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= python-xmp-toolkit
+DISTVERSION= 2.0.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= XMP Toolkit for working with metadata
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libexempi.so:textproc/exempi
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
+py27_TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+do-test:
+ @(cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v -e 'test_core')
+
+.include <bsd.port.mk>
diff --git a/textproc/py-python-xmp-toolkit/distinfo b/textproc/py-python-xmp-toolkit/distinfo
new file mode 100644
index 000000000000..6464c41d88b0
--- /dev/null
+++ b/textproc/py-python-xmp-toolkit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1558599984
+SHA256 (python-xmp-toolkit-2.0.1.tar.gz) = f8d912946ff9fd46ed5c7c355aa5d4ea193328b3f200909ef32d9a28a1419a38
+SIZE (python-xmp-toolkit-2.0.1.tar.gz) = 3566058
diff --git a/textproc/py-python-xmp-toolkit/pkg-descr b/textproc/py-python-xmp-toolkit/pkg-descr
new file mode 100644
index 000000000000..c8e6c74ad7d7
--- /dev/null
+++ b/textproc/py-python-xmp-toolkit/pkg-descr
@@ -0,0 +1,14 @@
+Python XMP Toolkit is a library for working with XMP (= Extensible Metadata
+Platform) metadata, as well as reading/writing XMP metadata stored in many
+different file formats.
+
+Python XMP Toolkit is wrapping Exempi (using ctypes), a C/C++ XMP library
+based on Adobe XMP Toolkit, ensuring that future updates to the XMP standard
+are easily incorporated into the library with a minimum amount of work.
+
+Python XMP Toolkit has been developed by:
+* ESA/Hubble - European Space Agency
+* ESO - European Southern Observatory
+* CRS4 - Centre for Advanced Studies, Research and Development in Sardinia
+
+WWW: https://github.com/python-xmp-toolkit/python-xmp-toolkit