aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-sphinx-hieroglyph/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-03-05 09:16:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-03-05 09:16:36 +0000
commitb3d0d3c4ea8af20cd6ffbf9a6a5b0f8188312eaa (patch)
tree717ab73796813614c77c4311537c2d4837414901 /textproc/py-sphinx-hieroglyph/Makefile
parent5647d6a75b3a32d29a599411ed6275d703a60ae2 (diff)
downloadports-b3d0d3c4ea8af20cd6ffbf9a6a5b0f8188312eaa.tar.gz
ports-b3d0d3c4ea8af20cd6ffbf9a6a5b0f8188312eaa.zip
Notes
Diffstat (limited to 'textproc/py-sphinx-hieroglyph/Makefile')
-rw-r--r--textproc/py-sphinx-hieroglyph/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/py-sphinx-hieroglyph/Makefile b/textproc/py-sphinx-hieroglyph/Makefile
new file mode 100644
index 000000000000..c6d89f716561
--- /dev/null
+++ b/textproc/py-sphinx-hieroglyph/Makefile
@@ -0,0 +1,26 @@
+# Created by: Andreas Sommer <andreas.sommer87@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= sphinx-hieroglyph
+PORTVERSION= 0.7.1
+CATEGORIES= textproc python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= andreas.sommer87@googlemail.com
+COMMENT= Sphinx extension which builds HTML presentations
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.3:textproc/py-sphinx
+
+USE_GITHUB= yes
+GH_ACCOUNT= nyergler
+GH_PROJECT= hieroglyph
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>