aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-transifex-client
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-02-19 06:05:43 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-02-19 06:05:43 +0000
commit2c057f2f813e3f35c7ee5b63f897a85db91d5639 (patch)
tree8ef53ee7c649113d31de85678f775491084f6df6 /textproc/py-transifex-client
parent81f0ed54c53e78002440c1bba0b5ca08fdbd5a33 (diff)
downloadports-2c057f2f813e3f35c7ee5b63f897a85db91d5639.tar.gz
ports-2c057f2f813e3f35c7ee5b63f897a85db91d5639.zip
textproc/py-transifex-client: Command line interface for Transifex
The Transifex Command-line Client is a command line tool that enables you to easily manage your translations within a project without the need of an elaborate UI system. You can use the command line client to easily create new resources, map locale files to translations and synchronize your Transifex project with your local repository and vice verca. Translators and localization managers can also use it to handle large volumes of translation files easily and without much hassle. WWW: http://www.transifex.com/
Notes
Notes: svn path=/head/; revision=345005
Diffstat (limited to 'textproc/py-transifex-client')
-rw-r--r--textproc/py-transifex-client/Makefile27
-rw-r--r--textproc/py-transifex-client/distinfo2
-rw-r--r--textproc/py-transifex-client/pkg-descr11
-rw-r--r--textproc/py-transifex-client/pkg-plist1
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/py-transifex-client/Makefile b/textproc/py-transifex-client/Makefile
new file mode 100644
index 000000000000..482321d616e4
--- /dev/null
+++ b/textproc/py-transifex-client/Makefile
@@ -0,0 +1,27 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= transifex-client
+PORTVERSION= 0.10
+CATEGORIES= textproc python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Command line interface for Transifex
+
+LICENSE= GPLv2
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+
+USE_GITHUB= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+GH_ACCOUNT= transifex
+GH_COMMIT= 84c9dcc
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
+.include <bsd.port.mk>
diff --git a/textproc/py-transifex-client/distinfo b/textproc/py-transifex-client/distinfo
new file mode 100644
index 000000000000..4b62f2bfd4b8
--- /dev/null
+++ b/textproc/py-transifex-client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (transifex-client-0.10.tar.gz) = 3de66de38b37d0be200b0a208a862c4f3f5f1561c9db55818045dc2b52a86870
+SIZE (transifex-client-0.10.tar.gz) = 71822
diff --git a/textproc/py-transifex-client/pkg-descr b/textproc/py-transifex-client/pkg-descr
new file mode 100644
index 000000000000..40a9c480fd59
--- /dev/null
+++ b/textproc/py-transifex-client/pkg-descr
@@ -0,0 +1,11 @@
+The Transifex Command-line Client is a command line tool that enables you
+to easily manage your translations within a project without the need of an
+elaborate UI system.
+
+You can use the command line client to easily create new resources, map
+locale files to translations and synchronize your Transifex project with
+your local repository and vice verca. Translators and localization managers
+can also use it to handle large volumes of translation files easily and
+without much hassle.
+
+WWW: https://www.transifex.com/
diff --git a/textproc/py-transifex-client/pkg-plist b/textproc/py-transifex-client/pkg-plist
new file mode 100644
index 000000000000..8fb5cc4556d5
--- /dev/null
+++ b/textproc/py-transifex-client/pkg-plist
@@ -0,0 +1 @@
+@comment $FreeBSD$