aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-wcmatch
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2021-02-27 12:28:21 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2021-02-27 12:28:21 +0000
commitae8f669d8f2119dc6eca4c451dada3dceede0b1a (patch)
tree982718e6b2478bb4d4295a921bef0a78aaa2bcef /textproc/py-wcmatch
parent1869626c43dc5ed063e76dd9566b32fb278a8bad (diff)
downloadports-ae8f669d8f2119dc6eca4c451dada3dceede0b1a.tar.gz
ports-ae8f669d8f2119dc6eca4c451dada3dceede0b1a.zip
Wildcard Match provides an enhanced fnmatch, glob, and pathlib library
in order to provide file matching and globbing that more closely follows the features found in Bash. In some ways these libraries are similar to Python's builtin libraries as they provide a similar interface to match, filter, and glob the file system. But they also include a number of features found in Bash's globbing such as backslash escaping, brace expansion, extended glob pattern groups, etc. They also add a number of new useful functions as well, such as globmatch which functions like fnmatch, but for paths. WWW: https://pypi.org/project/wcmatch/
Notes
Notes: svn path=/head/; revision=566697
Diffstat (limited to 'textproc/py-wcmatch')
-rw-r--r--textproc/py-wcmatch/Makefile29
-rw-r--r--textproc/py-wcmatch/distinfo3
-rw-r--r--textproc/py-wcmatch/pkg-descr11
3 files changed, 43 insertions, 0 deletions
diff --git a/textproc/py-wcmatch/Makefile b/textproc/py-wcmatch/Makefile
new file mode 100644
index 000000000000..e0edba2af211
--- /dev/null
+++ b/textproc/py-wcmatch/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= wcmatch
+PORTVERSION= 8.1.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Wildcard/glob file name matcher
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bracex>=2.1.1:textproc/py-bracex@${PY_FLAVOR}
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coverage>0:devel/py-coverage@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
+
+.include <bsd.port.mk>
diff --git a/textproc/py-wcmatch/distinfo b/textproc/py-wcmatch/distinfo
new file mode 100644
index 000000000000..ec4d88b390ee
--- /dev/null
+++ b/textproc/py-wcmatch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614428340
+SHA256 (wcmatch-8.1.1.tar.gz) = 7ba09191f9582e82d864829bdfbab02df46e26a46a304e57c7fe5652f07f297a
+SIZE (wcmatch-8.1.1.tar.gz) = 112831
diff --git a/textproc/py-wcmatch/pkg-descr b/textproc/py-wcmatch/pkg-descr
new file mode 100644
index 000000000000..4f535b26ea4c
--- /dev/null
+++ b/textproc/py-wcmatch/pkg-descr
@@ -0,0 +1,11 @@
+Wildcard Match provides an enhanced fnmatch, glob, and pathlib library
+in order to provide file matching and globbing that more closely
+follows the features found in Bash. In some ways these libraries are
+similar to Python's builtin libraries as they provide a similar
+interface to match, filter, and glob the file system. But they also
+include a number of features found in Bash's globbing such as
+backslash escaping, brace expansion, extended glob pattern groups,
+etc. They also add a number of new useful functions as well, such as
+globmatch which functions like fnmatch, but for paths.
+
+WWW: https://pypi.org/project/wcmatch/