aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-xhtml2pdf
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-24 20:06:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-24 20:06:33 +0000
commite71cc8fa60127ed53971232056dbd66b3ee8f3e8 (patch)
treed04864d396047442a3d745aee1d2fc227f90a4dc /textproc/py-xhtml2pdf
parent4da42450e92f75685d6887ef24b0c5066093970e (diff)
downloadports-e71cc8fa60127ed53971232056dbd66b3ee8f3e8.tar.gz
ports-e71cc8fa60127ed53971232056dbd66b3ee8f3e8.zip
Add py-xhtml2pdf 0.2.2
xhtml2pdf is a html2pdf converter using the ReportLab Toolkit, the HTML5lib and pyPdf. It supports HTML 5 and CSS 2.1 (and some of CSS 3). It is completely written in pure Python so it is platform independent. The main benefit of this tool that a user with Web skills like HTML and CSS is able to generate PDF templates very quickly without learning new technologies. WWW: https://github.com/xhtml2pdf/xhtml2pdf
Notes
Notes: svn path=/head/; revision=473216
Diffstat (limited to 'textproc/py-xhtml2pdf')
-rw-r--r--textproc/py-xhtml2pdf/Makefile31
-rw-r--r--textproc/py-xhtml2pdf/distinfo3
-rw-r--r--textproc/py-xhtml2pdf/pkg-descr8
3 files changed, 42 insertions, 0 deletions
diff --git a/textproc/py-xhtml2pdf/Makefile b/textproc/py-xhtml2pdf/Makefile
new file mode 100644
index 000000000000..e4cd6f6a2630
--- /dev/null
+++ b/textproc/py-xhtml2pdf/Makefile
@@ -0,0 +1,31 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xhtml2pdf
+PORTVERSION= 0.2.2
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= PDF generator using HTML and CSS
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>=1.0:www/py-html5lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httplib2>=0:www/py-httplib2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pdf2>=0:print/py-pdf2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}reportlab>=3.0:print/py-reportlab@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.0:devel/py-nose@${PY_FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|setup_requires=|tests_require=|' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/textproc/py-xhtml2pdf/distinfo b/textproc/py-xhtml2pdf/distinfo
new file mode 100644
index 000000000000..78ae1675ec33
--- /dev/null
+++ b/textproc/py-xhtml2pdf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529613498
+SHA256 (xhtml2pdf-0.2.2.tar.gz) = b7eba9a59771e0a4d786a814cc33b5554b0afd255e9dd735effce9f05efdc912
+SIZE (xhtml2pdf-0.2.2.tar.gz) = 97280
diff --git a/textproc/py-xhtml2pdf/pkg-descr b/textproc/py-xhtml2pdf/pkg-descr
new file mode 100644
index 000000000000..8491eda8c2ab
--- /dev/null
+++ b/textproc/py-xhtml2pdf/pkg-descr
@@ -0,0 +1,8 @@
+xhtml2pdf is a html2pdf converter using the ReportLab Toolkit, the HTML5lib and
+pyPdf. It supports HTML 5 and CSS 2.1 (and some of CSS 3). It is completely
+written in pure Python so it is platform independent.
+
+The main benefit of this tool that a user with Web skills like HTML and CSS is
+able to generate PDF templates very quickly without learning new technologies.
+
+WWW: https://github.com/xhtml2pdf/xhtml2pdf