aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-xlrd
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-22 22:09:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-22 22:09:37 +0000
commit79b10a91b4099a14207044f59c162738d03d9ad3 (patch)
treeb5cc76b67170b777a53035edfaecd957d423f773 /textproc/py-xlrd
parentebd38f8e8d020e7f2a834f850ecd420ded1b70f3 (diff)
downloadports-79b10a91b4099a14207044f59c162738d03d9ad3.tar.gz
ports-79b10a91b4099a14207044f59c162738d03d9ad3.zip
Notes
Diffstat (limited to 'textproc/py-xlrd')
-rw-r--r--textproc/py-xlrd/Makefile20
-rw-r--r--textproc/py-xlrd/distinfo3
-rw-r--r--textproc/py-xlrd/pkg-descr7
-rw-r--r--textproc/py-xlrd/pkg-plist40
4 files changed, 70 insertions, 0 deletions
diff --git a/textproc/py-xlrd/Makefile b/textproc/py-xlrd/Makefile
new file mode 100644
index 000000000000..f41dfcc980e9
--- /dev/null
+++ b/textproc/py-xlrd/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: xlrd
+# Date created: 2009-08-19
+# Whom: Dikshie
+#
+# $FreeBSD$
+#
+
+PORTNAME= xlrd
+PORTVERSION= 0.7.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dikshie@sfc.wide.ad.jp
+COMMENT= Reading data and formatting information from Excel files
+
+USE_PYTHON= 2.5-2.6
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-xlrd/distinfo b/textproc/py-xlrd/distinfo
new file mode 100644
index 000000000000..682ebdeb8b1e
--- /dev/null
+++ b/textproc/py-xlrd/distinfo
@@ -0,0 +1,3 @@
+MD5 (xlrd-0.7.1.tar.gz) = d0439a7ad1ae583a6ba3942efd0189c8
+SHA256 (xlrd-0.7.1.tar.gz) = ba11be7d2ebe7eeb208a23cc165bb7540451bcbad6da5cbf6947237568d16d14
+SIZE (xlrd-0.7.1.tar.gz) = 118302
diff --git a/textproc/py-xlrd/pkg-descr b/textproc/py-xlrd/pkg-descr
new file mode 100644
index 000000000000..099f5a07fae3
--- /dev/null
+++ b/textproc/py-xlrd/pkg-descr
@@ -0,0 +1,7 @@
+Library for developers to extract data from Microsoft Excel (tm)
+spreadsheet files
+
+Extract data from new and old Excel spreadsheets on any platform.
+Pure Python (2.1 to 2.6). Strong support for Excel dates. Unicode-aware.
+
+WWW: http://www.python-excel.org/
diff --git a/textproc/py-xlrd/pkg-plist b/textproc/py-xlrd/pkg-plist
new file mode 100644
index 000000000000..3f011dd30e5c
--- /dev/null
+++ b/textproc/py-xlrd/pkg-plist
@@ -0,0 +1,40 @@
+bin/runxlrd.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd-0.7.1-py2.6.egg-info
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/__init__.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/biffh.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/biffh.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/biffh.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/compdoc.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/compdoc.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/compdoc.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/doc/compdoc.html
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/doc/xlrd.html
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/examples/namesdemo.xls
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/examples/xlrdnameAPIdemo.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/examples/xlrdnameAPIdemo.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/examples/xlrdnameAPIdemo.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/formatting.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/formatting.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/formatting.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/formula.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/formula.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/formula.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/licences.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/licences.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/licences.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/sheet.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/sheet.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/sheet.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/timemachine.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/timemachine.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/timemachine.pyo
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/xldate.py
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/xldate.pyc
+lib/%%PYTHON_VERSION%%/site-packages/xlrd/xldate.pyo
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/xlrd/examples
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/xlrd/doc
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/xlrd
+@dirrm lib/%%PYTHON_VERSION%%/site-packages
+@dirrm lib/%%PYTHON_VERSION%%