aboutsummaryrefslogtreecommitdiff
path: root/textproc/randlm
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-08-30 14:43:09 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-08-30 14:43:09 +0000
commita826f595d2384365fcb9bc3c86b83f9763854528 (patch)
tree69da13d8dbd06fe327712febbcc4e715d5d69108 /textproc/randlm
parent4fb1d0468e9a3423fac06d3a4170d43943c323c1 (diff)
downloadports-a826f595d2384365fcb9bc3c86b83f9763854528.tar.gz
ports-a826f595d2384365fcb9bc3c86b83f9763854528.zip
New port: randlm.
A toolkit for bulding randomized language models. WWW: http://randlm.sourceforge.net/
Notes
Notes: svn path=/head/; revision=366625
Diffstat (limited to 'textproc/randlm')
-rw-r--r--textproc/randlm/Makefile30
-rw-r--r--textproc/randlm/distinfo2
-rw-r--r--textproc/randlm/files/patch-src-LDHT-MurmurHash3.cpp11
-rw-r--r--textproc/randlm/files/patch-src-LDHT-Util.h13
-rw-r--r--textproc/randlm/pkg-descr3
-rw-r--r--textproc/randlm/pkg-plist85
6 files changed, 144 insertions, 0 deletions
diff --git a/textproc/randlm/Makefile b/textproc/randlm/Makefile
new file mode 100644
index 000000000000..43486d14f285
--- /dev/null
+++ b/textproc/randlm/Makefile
@@ -0,0 +1,30 @@
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= randlm
+PORTVERSION= 0.2.5
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= A toolkit for building randomized language models
+
+BUILD_DEPENDS= ${LOCALBASE}/include/google/sparse_hash_map:${PORTSDIR}/devel/google-sparsehash
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
+RUN_DEPENDS= ${LOCALBASE}/include/google/sparse_hash_map:${PORTSDIR}/devel/google-sparsehash
+
+GNU_CONFIGURE= yes
+USE_GCC= yes
+USE_PERL5= run
+USE_AUTOTOOLS= libtoolize aclocal autoconf automake
+AUTOMAKE_ARGS= --add-missing
+USE_LDCONFIG= yes
+USES= libtool
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-patch:
+ cd ${WRKSRC}/hadoop && ${MV} strings.cpp strings.cc
+
+.include <bsd.port.mk>
diff --git a/textproc/randlm/distinfo b/textproc/randlm/distinfo
new file mode 100644
index 000000000000..a1884afc71dd
--- /dev/null
+++ b/textproc/randlm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (randlm-0.2.5.tar.gz) = e22e6e969cc971341af1414bf27c8ec0b88796055e5a132c9d4a47b80a3594fa
+SIZE (randlm-0.2.5.tar.gz) = 758741
diff --git a/textproc/randlm/files/patch-src-LDHT-MurmurHash3.cpp b/textproc/randlm/files/patch-src-LDHT-MurmurHash3.cpp
new file mode 100644
index 000000000000..fc55279b2917
--- /dev/null
+++ b/textproc/randlm/files/patch-src-LDHT-MurmurHash3.cpp
@@ -0,0 +1,11 @@
+--- ./src/LDHT/MurmurHash3.cpp.bak 2012-03-30 14:53:05.000000000 +0400
++++ ./src/LDHT/MurmurHash3.cpp 2014-08-30 17:56:33.000000000 +0400
+@@ -29,7 +29,7 @@
+
+ #else // defined(_MSC_VER)
+
+-#define FORCE_INLINE __attribute__((always_inline))
++#define FORCE_INLINE inline __attribute__((always_inline))
+
+ inline uint32_t rotl32 ( uint32_t x, int8_t r )
+ {
diff --git a/textproc/randlm/files/patch-src-LDHT-Util.h b/textproc/randlm/files/patch-src-LDHT-Util.h
new file mode 100644
index 000000000000..4d03aae6710f
--- /dev/null
+++ b/textproc/randlm/files/patch-src-LDHT-Util.h
@@ -0,0 +1,13 @@
+--- src/LDHT/Util.h.orig 2012-03-30 14:53:05.000000000 +0400
++++ src/LDHT/Util.h 2014-08-30 18:08:50.000000000 +0400
+@@ -10,6 +10,10 @@
+ #include <cstdlib>
+ #include <cstring>
+ #include <stdint.h>
++#include <unistd.h>
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+
+ #define V(expr) std::cerr << __FILE__ << ":" \
+ << __LINE__ << " " \
diff --git a/textproc/randlm/pkg-descr b/textproc/randlm/pkg-descr
new file mode 100644
index 000000000000..f47e451fe3cf
--- /dev/null
+++ b/textproc/randlm/pkg-descr
@@ -0,0 +1,3 @@
+A toolkit for bulding randomized language models.
+
+WWW: http://randlm.sourceforge.net/
diff --git a/textproc/randlm/pkg-plist b/textproc/randlm/pkg-plist
new file mode 100644
index 000000000000..36df968670a9
--- /dev/null
+++ b/textproc/randlm/pkg-plist
@@ -0,0 +1,85 @@
+bin/buildlm
+bin/countngrams
+bin/m_compute_ngram_counts_batch
+bin/querylm
+bin/r_compute_ngram_counts
+include/LDHT/BitArray.h
+include/LDHT/BloomFilter.h
+include/LDHT/Client.h
+include/LDHT/ClientLocal.h
+include/LDHT/FactoryCollection.h
+include/LDHT/HashFunction.h
+include/LDHT/HashFunctionFactory.h
+include/LDHT/HashFunctionUniversal.h
+include/LDHT/Logic.h
+include/LDHT/MethodRegistry.h
+include/LDHT/MurmurHash3.h
+include/LDHT/NewNgram.h
+include/LDHT/Protocol.h
+include/LDHT/ProtocolGroup.h
+include/LDHT/ProtocolQueue.h
+include/LDHT/Quantiser.h
+include/LDHT/Server.h
+include/LDHT/ServerLocator.h
+include/LDHT/ServerLocatorHash.h
+include/LDHT/TableChunk.h
+include/LDHT/TableChunkFactory.h
+include/LDHT/TableChunkLocator.h
+include/LDHT/TableChunkLocatorFactory.h
+include/LDHT/TableChunkLocatorHash.h
+include/LDHT/TableChunkLossyDict.h
+include/LDHT/TableDirectory.h
+include/LDHT/TableProtocol.h
+include/LDHT/TableProtocolLocalAdapter.h
+include/LDHT/TableRange.h
+include/LDHT/Thread.h
+include/LDHT/Transport.h
+include/LDHT/TransportPipe.h
+include/LDHT/TransportTCP.h
+include/LDHT/TypeDef.h
+include/LDHT/Util.h
+include/LDHT/VarIntStream.h
+include/LDHT/ticpp.h
+include/LDHT/ticpprc.h
+include/LDHT/tinystr.h
+include/LDHT/tinyxml.h
+include/RandLM/BloomMap.h
+include/RandLM/BloomierFilter.h
+include/RandLM/CountMinSketch.h
+include/RandLM/LogFreqBloomFilter.h
+include/RandLM/LogFreqSketch.h
+include/RandLM/LossyDict.h
+include/RandLM/RandLM.h
+include/RandLM/RandLMCache.h
+include/RandLM/RandLMFile.h
+include/RandLM/RandLMFilter.h
+include/RandLM/RandLMHash.h
+include/RandLM/RandLMHashCache.h
+include/RandLM/RandLMInfo.h
+include/RandLM/RandLMParams.h
+include/RandLM/RandLMPipeline.h
+include/RandLM/RandLMPipelineTool.h
+include/RandLM/RandLMPreproc.h
+include/RandLM/RandLMPreprocessor.h
+include/RandLM/RandLMQuantiser.h
+include/RandLM/RandLMStats.h
+include/RandLM/RandLMStruct.h
+include/RandLM/RandLMTool.h
+include/RandLM/RandLMTypes.h
+include/RandLM/RandLMUtils.h
+include/RandLM/RandLMVocab.h
+include/RandLM/fdstream.h
+lib/libLDHT.a
+lib/libLDHT.so
+lib/libLDHT.so.0
+lib/libLDHT.so.0.0.0
+lib/libRandLM.a
+lib/libRandLM.so
+lib/libRandLM.so.0
+lib/libRandLM.so.0.0.0
+lib/libticpp.a
+lib/libticpp.so
+lib/libticpp.so.0
+lib/libticpp.so.0.0.0
+@dirrm include/LDHT
+@dirrm include/RandLM