aboutsummaryrefslogtreecommitdiff
path: root/textproc/rapidxml
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-13 23:01:26 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-13 23:01:26 +0000
commit30bf2a4a63461601c8655a6ed9bc17b93008f31d (patch)
treee9c1620da47d9f0fbd8b3e42de4dac496df28773 /textproc/rapidxml
parent92bc99bae2bf62bb4f4f7872872b85f5cf5d55bf (diff)
downloadports-30bf2a4a63461601c8655a6ed9bc17b93008f31d.tar.gz
ports-30bf2a4a63461601c8655a6ed9bc17b93008f31d.zip
RapidXml is an attempt to create the fastest XML parser possible,
while retaining useability, portability and reasonable W3C compatibility. It is an in-situ parser written in modern C++, with parsing speed approaching that of strlen function executed on the same data. RapidXml has been around since 2006, and is being used by lots of people. HTC uses it in some of its mobile phones. If you are looking for a stable and fast parser, look no further. Integration with your project will be trivial, because entire library is contained in a single header file, and requires no building or configuration. WWW: http://rapidxml.sourceforge.net/
Notes
Notes: svn path=/head/; revision=354008
Diffstat (limited to 'textproc/rapidxml')
-rw-r--r--textproc/rapidxml/Makefile29
-rw-r--r--textproc/rapidxml/distinfo2
-rw-r--r--textproc/rapidxml/pkg-descr15
3 files changed, 46 insertions, 0 deletions
diff --git a/textproc/rapidxml/Makefile b/textproc/rapidxml/Makefile
new file mode 100644
index 000000000000..dda74e3474cc
--- /dev/null
+++ b/textproc/rapidxml/Makefile
@@ -0,0 +1,29 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rapidxml
+PORTVERSION= 1.13
+CATEGORIES= textproc
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Fast C++ library for parsing XML
+
+LICENSE= BSL
+
+USES= zip
+NO_BUILD= yes
+PLIST_FILES= include/rapidxml.hpp \
+ include/rapidxml_iterators.hpp \
+ include/rapidxml_print.hpp \
+ include/rapidxml_utils.hpp
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/*.hpp ${STAGEDIR}${PREFIX}/include
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manual.html ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/rapidxml/distinfo b/textproc/rapidxml/distinfo
new file mode 100644
index 000000000000..e5e1adf1c0c6
--- /dev/null
+++ b/textproc/rapidxml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rapidxml-1.13.zip) = c3f0b886374981bb20fabcf323d755db4be6dba42064599481da64a85f5b3571
+SIZE (rapidxml-1.13.zip) = 44163
diff --git a/textproc/rapidxml/pkg-descr b/textproc/rapidxml/pkg-descr
new file mode 100644
index 000000000000..c13bfcaf00b2
--- /dev/null
+++ b/textproc/rapidxml/pkg-descr
@@ -0,0 +1,15 @@
+RapidXml is an attempt to create the fastest XML parser possible,
+while retaining useability, portability and reasonable W3C
+compatibility. It is an in-situ parser written in modern C++, with
+parsing speed approaching that of strlen function executed on the
+same data.
+
+RapidXml has been around since 2006, and is being used by lots of
+people. HTC uses it in some of its mobile phones.
+
+If you are looking for a stable and fast parser, look no further.
+Integration with your project will be trivial, because entire library
+is contained in a single header file, and requires no building or
+configuration.
+
+WWW: http://rapidxml.sourceforge.net/