aboutsummaryrefslogtreecommitdiff
path: root/textproc/rasqal
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-05-11 12:23:23 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-05-11 12:23:23 +0000
commitb9e8e9b771669739b315082c52fca22eda504a7c (patch)
tree8ab43052c7d654026f0182d3561ef5c924ab236c /textproc/rasqal
parentafe8a0b09a357395514cdb2894bb56077c0f7371 (diff)
downloadports-b9e8e9b771669739b315082c52fca22eda504a7c.tar.gz
ports-b9e8e9b771669739b315082c52fca22eda504a7c.zip
- Split redland to rasqal and redland itself libraries
- Update raptor to 1.4.21 - Update rasqal to 0.9.19 - Update redland to 1.0.10 - Update redland-bindings to 1.0.10.1 - Bump portrevision on depended ports With hat on: kde@
Notes
Notes: svn path=/head/; revision=254131
Diffstat (limited to 'textproc/rasqal')
-rw-r--r--textproc/rasqal/Makefile48
-rw-r--r--textproc/rasqal/distinfo6
-rw-r--r--textproc/rasqal/files/patch-Makefile.in11
-rw-r--r--textproc/rasqal/files/patch-configure15
-rw-r--r--textproc/rasqal/pkg-descr9
-rw-r--r--textproc/rasqal/pkg-plist91
6 files changed, 26 insertions, 154 deletions
diff --git a/textproc/rasqal/Makefile b/textproc/rasqal/Makefile
index affb15efb9bc..ee4799434a98 100644
--- a/textproc/rasqal/Makefile
+++ b/textproc/rasqal/Makefile
@@ -5,57 +5,38 @@
#
# $FreeBSD$
#
-
-PORTNAME= redland
-PORTVERSION= 1.0.7
-PORTREVISION= 2
+PORTNAME= rasqal
+PORTVERSION= 0.9.19
CATEGORIES= textproc
MASTER_SITES= SF/librdf/${PORTNAME}/${PORTVERSION} \
http://librdf.org/dist/source/
-
MAINTAINER= kde@FreeBSD.org
COMMENT= A high-level interface for RDF
-LIB_DEPENDS= raptor.2:${PORTSDIR}/textproc/raptor
+LIB_DEPENDS= raptor.3:${PORTSDIR}/textproc/raptor \
+ pcre.0:${PORTSDIR}/devel/pcre
-USE_BDB= yes
-WITH_BDB_HIGHEST= yes
-INVALID_BDB_VER=2
USE_GNOME= gnomehack gnometarget lthack pkgconfig
USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CPPFLAGS= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
+CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-raptor=system \
- --with-rasqal=internal \
- --with-threestore=no \
- --with-sqlite=no
+CONFIGURE_ARGS= --with-raptor=system
USE_LDCONFIG= yes
USE_PERL5_BUILD= yes
-MAN1= rasqal-config.1 rdfproc.1 redland-config.1 \
- redland-db-upgrade.1 roqet.1
-MAN3= librasqal.3 redland.3
+MAN1= rasqal-config.1 roqet.1
+MAN3= librasqal.3
-OPTIONS+= MYSQL "Use MySQL instead of BDB" off
OPTIONS+= MPFR "Use MPFR library for decimals (implies GMP)" off
OPTIONS+= GMP "Use Gnu MP library for decimals" off
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_MYSQL)
-USE_MYSQL= yes
-CONFIGURE_ARGS+=--with-mysql=yes
-PLIST_SUB+= MYSQL=""
-.else
-CONFIGURE_ARGS+=--with-mysql=no
-PLIST_SUB+= MYSQL="@comment "
-.endif
+.include <bsd.port.options.mk>
# Set to mpfr if MPFR is on, gmp if only GMP is on and none if neither.
# This guards against $user setting both GMP and MPFR, since we can't be
@@ -70,13 +51,4 @@ LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
CONFIGURE_ARGS+= --with-decimal=none
.endif
-pre-everything::
- @${ECHO_CMD} "You can choose BDB version by setting WITH_BDB_VER to one off:"
- @${ECHO_CMD} "3 40 41 42 43 44 3+ 40+ 41+ 42+ 43+ 44+ (current: ${BDB_VER})"
-. if defined(WITH_MYSQL)
- @${ECHO_CMD} "MySQL version to be used: ${MYSQL_VER}"
- @${ECHO_CMD} "If you don't have MySQL installed you can stop the build now"
- @${ECHO_CMD} "and set WITH_MYSQL_VER to the desired version"
-. endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/rasqal/distinfo b/textproc/rasqal/distinfo
index e54a28975bfb..8528315cb48f 100644
--- a/textproc/rasqal/distinfo
+++ b/textproc/rasqal/distinfo
@@ -1,3 +1,3 @@
-MD5 (redland-1.0.7.tar.gz) = 4c066d3dcf6c25f8fb8c9007e73f293c
-SHA256 (redland-1.0.7.tar.gz) = 5fe48265b770bae89c47b3a55711adbfba368dfa120ab8112bde539b210426fc
-SIZE (redland-1.0.7.tar.gz) = 3739013
+MD5 (rasqal-0.9.19.tar.gz) = 9bc1b40ffe1bdc794887d845d153bd4e
+SHA256 (rasqal-0.9.19.tar.gz) = a042846e8b7af52d9d66fba788c9d579e58c535cfaf80d33dc0bd69bf6ffeb08
+SIZE (rasqal-0.9.19.tar.gz) = 1232729
diff --git a/textproc/rasqal/files/patch-Makefile.in b/textproc/rasqal/files/patch-Makefile.in
deleted file mode 100644
index eb18debc2f80..000000000000
--- a/textproc/rasqal/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Wed Aug 4 12:17:19 2004
-+++ Makefile.in Wed Aug 4 12:18:49 2004
-@@ -257,7 +257,7 @@
- # to ensure that the raptor and rasqal subdirectories are called
- # as CONFIG_SUBDIR directories.
- #
--SUBDIRS = @LOCAL_SUBDIRS@ librdf examples utils demos docs data
-+SUBDIRS = @LOCAL_SUBDIRS@ librdf utils demos docs data
- EXTRA_DIST = ChangeLog ChangeLog.1 ChangeLog.2 ChangeLog.3 ChangeLog.4 \
- README NEWS LICENSE.txt TODO \
- README.html NEWS.html LICENSE.html TODO.html \
diff --git a/textproc/rasqal/files/patch-configure b/textproc/rasqal/files/patch-configure
deleted file mode 100644
index bdb0881dd344..000000000000
--- a/textproc/rasqal/files/patch-configure
+++ /dev/null
@@ -1,15 +0,0 @@
---- configure.orig Tue Sep 9 00:06:31 2003
-+++ configure Tue Sep 9 09:03:46 2003
-@@ -12735,9 +12735,9 @@
- CFLAGS="$MAINTAINER_CFLAGS $CFLAGS"
- fi
-
--LIBS=
--CPPFLAGS=
--LDFLAGS=
-+LIBS="$LIBS"
-+CPPFLAGS="$CPPFLAGS"
-+LDFLAGS="$LDFLAGS"
-
- LIBRDF_LIBTOOLLIBS=librdf.la
-
diff --git a/textproc/rasqal/pkg-descr b/textproc/rasqal/pkg-descr
index 022367271ed6..bcd545a95fb9 100644
--- a/textproc/rasqal/pkg-descr
+++ b/textproc/rasqal/pkg-descr
@@ -1,7 +1,6 @@
-Redland is a library that provides a high-level interface for RDF allowing
-the model to be stored, queried and manipulated. Redland implements each
-of the RDF model concepts in its own class so provides an object based API
-for them. Some of the classes providing the parsers, storage mechanisms and
-other elements are built as modules that can be added or removed as required.
+Rasqal is a free software / Open Source C library that handles Resource
+Description Framework (RDF) query syntaxes, query construction and query
+execution returning result bindings. The supported query languages are
+SPARQL and RDQL.
WWW: http://librdf.org/
diff --git a/textproc/rasqal/pkg-plist b/textproc/rasqal/pkg-plist
index 114cbe7d148d..b8039a7dd3a7 100644
--- a/textproc/rasqal/pkg-plist
+++ b/textproc/rasqal/pkg-plist
@@ -1,113 +1,40 @@
bin/rasqal-config
-bin/rdfproc
-bin/redland-config
-bin/redland-db-upgrade
bin/roqet
-include/librdf.h
-include/rasqal.h
-include/rdf_concepts.h
-include/rdf_digest.h
-include/rdf_hash.h
-include/rdf_init.h
-include/rdf_iterator.h
-include/rdf_log.h
-include/rdf_model.h
-include/rdf_node.h
-include/rdf_parser.h
-include/rdf_query.h
-include/rdf_serializer.h
-include/rdf_statement.h
-include/rdf_storage.h
-include/rdf_stream.h
-include/rdf_uri.h
-include/rdf_utf8.h
-include/redland.h
+include/rasqal/rasqal.h
lib/librasqal.a
lib/librasqal.la
lib/librasqal.so
-lib/librasqal.so.0
-lib/librdf.a
-lib/librdf.la
-lib/librdf.so
-lib/librdf.so.0
+lib/librasqal.so.2
libdata/pkgconfig/rasqal.pc
-libdata/pkgconfig/redland.pc
share/gtk-doc/html/rasqal/home.png
share/gtk-doc/html/rasqal/index.html
share/gtk-doc/html/rasqal/index.sgml
-share/gtk-doc/html/rasqal/ix01.html
+share/gtk-doc/html/rasqal/indexes.html
share/gtk-doc/html/rasqal/left.png
-share/gtk-doc/html/rasqal/pt01.html
share/gtk-doc/html/rasqal/rasqal-section-data.html
share/gtk-doc/html/rasqal/rasqal-section-expression.html
share/gtk-doc/html/rasqal/rasqal-section-general.html
share/gtk-doc/html/rasqal/rasqal-section-graph-pattern.html
share/gtk-doc/html/rasqal/rasqal-section-literal.html
share/gtk-doc/html/rasqal/rasqal-section-prefix.html
+share/gtk-doc/html/rasqal/rasqal-section-query-results-formatter.html
share/gtk-doc/html/rasqal/rasqal-section-query-results.html
share/gtk-doc/html/rasqal/rasqal-section-query.html
-share/gtk-doc/html/rasqal/rasqal-section-query-results-formatter.html
+share/gtk-doc/html/rasqal/rasqal-section-row.html
share/gtk-doc/html/rasqal/rasqal-section-triple.html
share/gtk-doc/html/rasqal/rasqal-section-triples-source.html
+share/gtk-doc/html/rasqal/rasqal-section-updates.html
share/gtk-doc/html/rasqal/rasqal-section-variable.html
+share/gtk-doc/html/rasqal/rasqal-section-variables-table.html
share/gtk-doc/html/rasqal/rasqal-section-xsd.html
share/gtk-doc/html/rasqal/rasqal.devhelp
share/gtk-doc/html/rasqal/rasqal.devhelp2
share/gtk-doc/html/rasqal/rasqal.html
+share/gtk-doc/html/rasqal/reference-manual.html
share/gtk-doc/html/rasqal/right.png
share/gtk-doc/html/rasqal/style.css
share/gtk-doc/html/rasqal/up.png
-share/gtk-doc/html/redland/home.png
-share/gtk-doc/html/redland/index.html
-share/gtk-doc/html/redland/index.sgml
-share/gtk-doc/html/redland/indexes.html
-share/gtk-doc/html/redland/introduction.html
-share/gtk-doc/html/redland/left.png
-share/gtk-doc/html/redland/objects.html
-share/gtk-doc/html/redland/redland-concepts.html
-share/gtk-doc/html/redland/redland-digest.html
-share/gtk-doc/html/redland/redland-files.html
-share/gtk-doc/html/redland/redland-hash.html
-share/gtk-doc/html/redland/redland-heuristics.html
-share/gtk-doc/html/redland/redland-iterator.html
-share/gtk-doc/html/redland/redland-list.html
-share/gtk-doc/html/redland/redland-log.html
-share/gtk-doc/html/redland/redland-model.html
-share/gtk-doc/html/redland/redland-node.html
-share/gtk-doc/html/redland/redland-parser.html
-share/gtk-doc/html/redland/redland-query-results.html
-share/gtk-doc/html/redland/redland-query.html
-share/gtk-doc/html/redland/redland-serializer.html
-share/gtk-doc/html/redland/redland-statement.html
-share/gtk-doc/html/redland/redland-storage.html
-share/gtk-doc/html/redland/redland-storage-module-file.html
-share/gtk-doc/html/redland/redland-storage-module-hashes.html
-share/gtk-doc/html/redland/redland-storage-module-memory.html
-share/gtk-doc/html/redland/redland-storage-module-mysql.html
-share/gtk-doc/html/redland/redland-storage-module-postgresql.html
-share/gtk-doc/html/redland/redland-storage-module-sqlite.html
-share/gtk-doc/html/redland/redland-storage-module-tstore.html
-share/gtk-doc/html/redland/redland-storage-module-uri.html
-share/gtk-doc/html/redland/redland-storage-modules.html
-share/gtk-doc/html/redland/redland-stream.html
-share/gtk-doc/html/redland/redland-unicode.html
-share/gtk-doc/html/redland/redland-uri.html
-share/gtk-doc/html/redland/redland-world.html
-share/gtk-doc/html/redland/redland.devhelp
-share/gtk-doc/html/redland/redland.devhelp2
-share/gtk-doc/html/redland/redland.html
-share/gtk-doc/html/redland/reference-manual.html
-share/gtk-doc/html/redland/right.png
-share/gtk-doc/html/redland/style.css
-share/gtk-doc/html/redland/tutorial.html
-share/gtk-doc/html/redland/up.png
-%%MYSQL%%share/redland/mysql-v1.ttl
-%%MYSQL%%share/redland/mysql-v2.ttl
-%%DATADIR%%/Redland.i
-@dirrm lib/redland
-@dirrm %%DATADIR%%
@exec mkdir -p %D/share/gtk-doc/html/rasqal
@dirrm share/gtk-doc/html/rasqal
-@exec mkdir -p %D/share/gtk-doc/html/redland
-@dirrm share/gtk-doc/html/redland
@dirrmtry share/gtk-doc
+@dirrm include/rasqal