aboutsummaryrefslogtreecommitdiff
path: root/textproc/re-flex
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2019-02-14 17:42:19 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2019-02-14 17:42:19 +0000
commit00022c3fb14e9bb5047db55aceae755302d4bf79 (patch)
tree478bc8ddbab241dc2457aa27a4520b8ced71b5d3 /textproc/re-flex
parentee8f88abd961f11b5a5778abe162656aff034276 (diff)
downloadports-00022c3fb14e9bb5047db55aceae755302d4bf79.tar.gz
ports-00022c3fb14e9bb5047db55aceae755302d4bf79.zip
textproc/re-flex: add new port
RE/flex is a free and open-source alternative to the fast lexical analyzer Flex. RE/flex generates fast lexical analyzers for C++, also known as "scanners", "lexers", or "tokenizers". RE/flex offers many new useful features including Unicode support, indent/nodent/dedent anchors, word boundaries, lazy quantifiers (non-greedy, lazy repeats), and performance tuning options. The RE/flex software also includes a very fast stand-alone regex library for C++. WWW: https://www.genivia.com/reflex.html
Notes
Notes: svn path=/head/; revision=492926
Diffstat (limited to 'textproc/re-flex')
-rw-r--r--textproc/re-flex/Makefile28
-rw-r--r--textproc/re-flex/distinfo3
-rw-r--r--textproc/re-flex/pkg-descr8
-rw-r--r--textproc/re-flex/pkg-plist22
4 files changed, 61 insertions, 0 deletions
diff --git a/textproc/re-flex/Makefile b/textproc/re-flex/Makefile
new file mode 100644
index 000000000000..053e8ae2c8a7
--- /dev/null
+++ b/textproc/re-flex/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= re-flex
+PORTVERSION= 1.0.12
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Regex-centric, fast and flexible scanner generator for C++
+
+LICENSE= BSD3CLAUSE
+
+CONFLICTS_INSTALL= reflex
+
+USES= autoreconf compiler:c++11-lib gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= Genivia
+GH_PROJECT= RE-flex
+
+GNU_CONFIGURE= yes
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/reflex
+ (cd ${WRKSRC}/include/reflex && \
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/include/reflex)
+
+.include <bsd.port.mk>
diff --git a/textproc/re-flex/distinfo b/textproc/re-flex/distinfo
new file mode 100644
index 000000000000..19321505d862
--- /dev/null
+++ b/textproc/re-flex/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1550144678
+SHA256 (Genivia-RE-flex-v1.0.12_GH0.tar.gz) = b10baf1aca26410013aafc5094ca79a837711a458cc41fc170a0e9d21d60667a
+SIZE (Genivia-RE-flex-v1.0.12_GH0.tar.gz) = 3926377
diff --git a/textproc/re-flex/pkg-descr b/textproc/re-flex/pkg-descr
new file mode 100644
index 000000000000..4038fc73ddf4
--- /dev/null
+++ b/textproc/re-flex/pkg-descr
@@ -0,0 +1,8 @@
+RE/flex is a free and open-source alternative to the fast lexical analyzer
+Flex. RE/flex generates fast lexical analyzers for C++, also known as
+"scanners", "lexers", or "tokenizers". RE/flex offers many new useful features
+including Unicode support, indent/nodent/dedent anchors, word boundaries, lazy
+quantifiers (non-greedy, lazy repeats), and performance tuning options. The
+RE/flex software also includes a very fast stand-alone regex library for C++.
+
+WWW: https://www.genivia.com/reflex.html
diff --git a/textproc/re-flex/pkg-plist b/textproc/re-flex/pkg-plist
new file mode 100644
index 000000000000..7485480e47e2
--- /dev/null
+++ b/textproc/re-flex/pkg-plist
@@ -0,0 +1,22 @@
+bin/reflex
+include/reflex/abslexer.h
+include/reflex/absmatcher.h
+include/reflex/bits.h
+include/reflex/boostmatcher.h
+include/reflex/convert.h
+include/reflex/debug.h
+include/reflex/error.h
+include/reflex/flexlexer.h
+include/reflex/input.h
+include/reflex/matcher.h
+include/reflex/pattern.h
+include/reflex/posix.h
+include/reflex/ranges.h
+include/reflex/setop.h
+include/reflex/stdmatcher.h
+include/reflex/timer.h
+include/reflex/traits.h
+include/reflex/unicode.h
+include/reflex/utf8.h
+lib/libreflex.a
+man/man1/reflex.1.gz