aboutsummaryrefslogtreecommitdiff
path: root/textproc/resume
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-28 16:18:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-28 16:18:59 +0000
commit2ee8e5f59b465548955ce8cc76ce2ee9405cf856 (patch)
tree053f8737940f3b8f6f4b8f09e502cbe719142ed8 /textproc/resume
parentdea70cd2809cc2d796e0c1b6b204be6477e64bea (diff)
downloadports-2ee8e5f59b465548955ce8cc76ce2ee9405cf856.tar.gz
ports-2ee8e5f59b465548955ce8cc76ce2ee9405cf856.zip
Notes
Diffstat (limited to 'textproc/resume')
-rw-r--r--textproc/resume/Makefile26
1 files changed, 10 insertions, 16 deletions
diff --git a/textproc/resume/Makefile b/textproc/resume/Makefile
index d940d42031cb..4b537630d04f 100644
--- a/textproc/resume/Makefile
+++ b/textproc/resume/Makefile
@@ -16,31 +16,25 @@ USE_JAVA= yes
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|\.\./\.\./css|css|' ${WRKSRC}/xsl/params.xsl
${FIND} ${WRKSRC} -name '*.bak' -delete
do-install:
- ${MKDIR} ${PREFIX}/share/xml/${PORTNAME}
- ${CP} -R ${WRKSRC}/dtd/* ${PREFIX}/share/xml/${PORTNAME}
- ${MKDIR} ${PREFIX}/share/xsl/${PORTNAME}
- ${CP} -R ${WRKSRC}/xsl/* ${PREFIX}/share/xsl/${PORTNAME}
- ${CP} -R ${WRKSRC}/css ${PREFIX}/share/xsl/${PORTNAME}/format
- ${INSTALL_DATA} ${WRKSRC}/java/*.jar ${JAVAJARDIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/xml/${PORTNAME}
+ ${CP} -R ${WRKSRC}/dtd/* ${STAGEDIR}${PREFIX}/share/xml/${PORTNAME}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/xsl/${PORTNAME}
+ ${CP} -R ${WRKSRC}/xsl/* ${STAGEDIR}${PREFIX}/share/xsl/${PORTNAME}
+ ${CP} -R ${WRKSRC}/css ${STAGEDIR}${PREFIX}/share/xsl/${PORTNAME}/format
+ ${INSTALL_DATA} ${WRKSRC}/java/*.jar ${STAGEDIR}${JAVAJARDIR}
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
- ${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" pkg-message >${PKGMESSAGE}
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>