aboutsummaryrefslogtreecommitdiff
path: root/textproc/retext
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2019-09-09 18:42:31 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2019-09-09 18:42:31 +0000
commit2a819f07bbaab7f15cc4a2c874541299ea796041 (patch)
treed57807774271ab8dab81f90d7a0d8e5022b5a1e8 /textproc/retext
parent7942b37f98c30c81f23b9bbfdb765ec954186904 (diff)
downloadports-2a819f07bbaab7f15cc4a2c874541299ea796041.tar.gz
ports-2a819f07bbaab7f15cc4a2c874541299ea796041.zip
Teach setup.py how to find lrelease.
This patch is needed for upcoming Qt 5.13 Reported by: adridg@
Notes
Notes: svn path=/head/; revision=511653
Diffstat (limited to 'textproc/retext')
-rw-r--r--textproc/retext/Makefile3
-rw-r--r--textproc/retext/files/patch-setup.py11
2 files changed, 14 insertions, 0 deletions
diff --git a/textproc/retext/Makefile b/textproc/retext/Makefile
index c3b2b8d6ead6..811008ef2248 100644
--- a/textproc/retext/Makefile
+++ b/textproc/retext/Makefile
@@ -31,4 +31,7 @@ BINARY_ALIAS= lrelease=${LRELEASE}
NO_ARCH= yes
+post-patch:
+ ${REINPLACE_CMD} -e "s,lrelease,${LOCALBASE}/bin/lrelease," ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/textproc/retext/files/patch-setup.py b/textproc/retext/files/patch-setup.py
new file mode 100644
index 000000000000..fef973a8c849
--- /dev/null
+++ b/textproc/retext/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2019-09-09 20:33:15.181197000 +0200
++++ setup.py 2019-09-09 20:37:49.730010000 +0200
+@@ -57,7 +57,7 @@
+ def run(self):
+ for ts_file in glob(join('locale', '*.ts')):
+ try:
+- check_call(('lrelease', ts_file), env={'QT_SELECT': '5'})
++ check_call(('lrelease', ts_file), env={'QT_SELECT': 'qt5'})
+ except Exception as e:
+ log.warn('Failed to build translations: %s', e)
+ break