aboutsummaryrefslogtreecommitdiff
path: root/textproc/rfcdiff
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-15 18:31:10 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-15 18:31:10 +0000
commit989e78c716bc0835839457a8ade7944bc8b2b9b4 (patch)
treed650ad3b9d370c8ed659865499851b3524ebf0b1 /textproc/rfcdiff
parent573b80db754f267147c6c7518b9e03b4b366f872 (diff)
downloadports-989e78c716bc0835839457a8ade7944bc8b2b9b4.tar.gz
ports-989e78c716bc0835839457a8ade7944bc8b2b9b4.zip
- Depend on bash and replace /bin/bash in the script
- Depend on gawk - Depend on wdiff PR: ports/82265, ports/82284 Submitted by: Bengt Ahlgren <bengta@sics.se>, maintainer
Notes
Notes: svn path=/head/; revision=137500
Diffstat (limited to 'textproc/rfcdiff')
-rw-r--r--textproc/rfcdiff/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/textproc/rfcdiff/Makefile b/textproc/rfcdiff/Makefile
index e03e16bd2656..aaf99e88f2fc 100644
--- a/textproc/rfcdiff/Makefile
+++ b/textproc/rfcdiff/Makefile
@@ -6,6 +6,7 @@
PORTNAME= rfcdiff
PORTVERSION= 1.23
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://ietf.levkowetz.com/tools/${PORTNAME}/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -14,14 +15,23 @@ EXTRACT_SUFX=
MAINTAINER= lars.eggert@gmx.net
COMMENT= Compare two versions of an Internet Draft and produce a diff
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ gawk:${PORTSDIR}/lang/gawk \
+ wdiff:${PORTSDIR}/textproc/wdiff
+
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= ${WRKSRC}
NO_WRKSUBDIR= YES
NO_BUILD= YES
+USE_REINPLACE= YES
PLIST_FILES= bin/rfcdiff
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \
+ ${WRKSRC}/${DISTNAME}
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}