aboutsummaryrefslogtreecommitdiff
path: root/textproc/ripgrep
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-11-26 08:34:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-11-26 08:34:51 +0000
commit029465f81b75fbf43a1e20d6326e38d7c437a330 (patch)
treef78613910b1a63d6ede593d3b5b5aef1e885a924 /textproc/ripgrep
parent8377e576c0d42233df1e2d56c6e13375c659731d (diff)
downloadports-029465f81b75fbf43a1e20d6326e38d7c437a330.tar.gz
ports-029465f81b75fbf43a1e20d6326e38d7c437a330.zip
textproc/ripgrep: enable PCRE2 support by default
PR: 233317 Approved by: Petteri Valkonen (maintainer)
Notes
Notes: svn path=/head/; revision=485929
Diffstat (limited to 'textproc/ripgrep')
-rw-r--r--textproc/ripgrep/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/textproc/ripgrep/Makefile b/textproc/ripgrep/Makefile
index dcca091dda0f..ded966af5fea 100644
--- a/textproc/ripgrep/Makefile
+++ b/textproc/ripgrep/Makefile
@@ -5,7 +5,7 @@
PORTNAME= ripgrep
DISTVERSION= 0.10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MAINTAINER= petteri.valkonen@iki.fi
@@ -110,7 +110,8 @@ PLIST_FILES= bin/rg \
PORTDOCS= CHANGELOG.md FAQ.md GUIDE.md
-OPTIONS_DEFINE= DOCS SIMD
+OPTIONS_DEFINE= DOCS PCRE2 SIMD
+OPTIONS_DEFAULT=PCRE2
OPTIONS_DEFINE_amd64= AVX
OPTIONS_DEFINE_i386= AVX
@@ -124,6 +125,10 @@ AVX_DESC= ${SSE_DESC:S/SSE/AVX/}
AVX_VARS= CARGO_FEATURES+=avx-accel RUSTFLAGS+="-C target-feature=+avx"
AVX_IMPLIES= SIMD
+PCRE2_DESC= ${PCRE_DESC} version 2
+PCRE2_LIB_DEPENDS= libpcre2-8.so:devel/pcre2
+PCRE2_VARS= CARGO_FEATURES+=pcre2
+
# simd crate uses cfg_target_feature which isn't stable yet, so unlock
# unstable features similar to how lang/rust bootstraps. www/firefox
# uses the same hack when building with --enable-rust-simd.