aboutsummaryrefslogtreecommitdiff
path: root/textproc/rtfx
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-23 03:03:38 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-23 03:03:38 +0000
commite3966e0359bce51029692d64a27dc50706401ea5 (patch)
treec1295e7a0cf9de87cc8aa86f3efa0b334e442d28 /textproc/rtfx
parent4cc1f89f82f44bc091bc8132031307088ec57acf (diff)
downloadports-e3966e0359bce51029692d64a27dc50706401ea5.tar.gz
ports-e3966e0359bce51029692d64a27dc50706401ea5.zip
Notes
Diffstat (limited to 'textproc/rtfx')
-rw-r--r--textproc/rtfx/Makefile14
-rw-r--r--textproc/rtfx/distinfo6
-rw-r--r--textproc/rtfx/files/extra-patch-src::domhelpers.h-gcc29518
-rw-r--r--textproc/rtfx/files/extra-patch-src::reference.h-gcc34215
-rw-r--r--textproc/rtfx/files/extra-patch-src::sablo.h-gcc34215
-rw-r--r--textproc/rtfx/files/patch-libs-Makefile.in20
-rw-r--r--textproc/rtfx/files/patch-libs-domc-Makefile8
-rw-r--r--textproc/rtfx/pkg-plist1
8 files changed, 36 insertions, 61 deletions
diff --git a/textproc/rtfx/Makefile b/textproc/rtfx/Makefile
index fbaad2b7e0be..5c78f874b059 100644
--- a/textproc/rtfx/Makefile
+++ b/textproc/rtfx/Makefile
@@ -6,30 +6,26 @@
#
PORTNAME= rtfx
-PORTVERSION= 0.9.3
+PORTVERSION= 1.0
CATEGORIES= textproc
MASTER_SITES= http://memberwebs.com/nielsen/software/rtfx/
MAINTAINER= clsung@FreeBSD.org
COMMENT= An RTF to XML converter
-LIB_DEPENDS= sablot.70:${PORTSDIR}/textproc/sablotron
+LIB_DEPENDS= mba.1:${PORTSDIR}/devel/libmba
HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX} --datarootdir=${PREFIX}
USE_GMAKE= yes
+PLIST_FILES= bin/rtfx
MAN1= rtfx.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 500035
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src::domhelpers.h-gcc295
-post-patch:
- @${REINPLACE_CMD} -e "s/ //g" ${WRKSRC}/src/xmlcomposer.cpp
-.endif
-.if ${OSVERSION} >= 502124
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src::reference.h-gcc342 \
- ${FILESDIR}/extra-patch-src::sablo.h-gcc342
+BROKEN= does not build on 4.x
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/rtfx/distinfo b/textproc/rtfx/distinfo
index 6a3ab8ec0641..7e5db781d21d 100644
--- a/textproc/rtfx/distinfo
+++ b/textproc/rtfx/distinfo
@@ -1,3 +1,3 @@
-MD5 (rtfx-0.9.3.tar.gz) = da6f3c89e70a3f7e51188438dbf633f9
-SHA256 (rtfx-0.9.3.tar.gz) = bf480e8848af56a7d4cdc585843192dbe49d08609cce76539de38d16b4c461a9
-SIZE (rtfx-0.9.3.tar.gz) = 350221
+MD5 (rtfx-1.0.tar.gz) = dd24f5d86a26c8deeacc13caca56b35f
+SHA256 (rtfx-1.0.tar.gz) = be7e81c657de5f3d60563f09fe56138883e8df4ef7d9419bf999942a57098f9c
+SIZE (rtfx-1.0.tar.gz) = 1292208
diff --git a/textproc/rtfx/files/extra-patch-src::domhelpers.h-gcc295 b/textproc/rtfx/files/extra-patch-src::domhelpers.h-gcc295
deleted file mode 100644
index bbdf15cc1325..000000000000
--- a/textproc/rtfx/files/extra-patch-src::domhelpers.h-gcc295
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/domhelpers.h.orig Sun Jul 25 06:37:15 2004
-+++ src/domhelpers.h Thu Jul 29 07:56:00 2004
-@@ -44,6 +44,15 @@
- #include <stack>
- #include <set>
-
-+template <class _Category, class _Tp, class _Distance = ptrdiff_t,
-+ class _Pointer = _Tp*, class _Reference = _Tp&>
-+struct iterator {
-+typedef _Category iterator_category;
-+typedef _Tp value_type;
-+typedef _Distance difference_type;
-+typedef _Pointer pointer;
-+typedef _Reference reference;
-+};
- /*
- * DOMHelpers
- *
diff --git a/textproc/rtfx/files/extra-patch-src::reference.h-gcc342 b/textproc/rtfx/files/extra-patch-src::reference.h-gcc342
deleted file mode 100644
index bf185cd5dc7c..000000000000
--- a/textproc/rtfx/files/extra-patch-src::reference.h-gcc342
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/reference.h.orig Fri Jul 23 05:03:03 2004
-+++ src/reference.h Sat Aug 14 14:41:14 2004
-@@ -57,10 +57,10 @@
- addref();
- }
-
-- Reference(C* ptr, bool addref)
-+ Reference(C* ptr, bool has_addref)
- {
- m_ptr = ptr;
-- if(addref)
-+ if(has_addref)
- addref();
- }
-
diff --git a/textproc/rtfx/files/extra-patch-src::sablo.h-gcc342 b/textproc/rtfx/files/extra-patch-src::sablo.h-gcc342
deleted file mode 100644
index 7d1148923b08..000000000000
--- a/textproc/rtfx/files/extra-patch-src::sablo.h-gcc342
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/sablo.h.orig Sat Jul 24 12:18:06 2004
-+++ src/sablo.h Sat Aug 14 14:42:45 2004
-@@ -146,10 +146,10 @@
- addref();
- }
-
-- Ref(C* ptr, bool addref)
-+ Ref(C* ptr, bool has_addref)
- {
- m_ptr = ptr;
-- if(addref)
-+ if(has_addref)
- addref();
- }
-
diff --git a/textproc/rtfx/files/patch-libs-Makefile.in b/textproc/rtfx/files/patch-libs-Makefile.in
new file mode 100644
index 000000000000..abcf33aff361
--- /dev/null
+++ b/textproc/rtfx/files/patch-libs-Makefile.in
@@ -0,0 +1,20 @@
+--- libs/Makefile.in.orig Tue Oct 24 10:48:44 2006
++++ libs/Makefile.in Sun Nov 5 23:33:49 2006
+@@ -131,7 +131,7 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-EXTRA_DIST = files prepare-libraries.sh libmba domc
++EXTRA_DIST = files prepare-libraries.sh domc
+ all: all-am
+
+ .SUFFIXES:
+@@ -287,8 +287,6 @@
+ # as the libraries' make files aren't automake compatible
+
+ all:
+- chmod -R u+rw $(srcdir)/libmba
+- $(MAKE) -C $(srcdir)/libmba $@
+ chmod -R u+rw $(srcdir)/domc
+ $(MAKE) -C $(srcdir)/domc $@
+
diff --git a/textproc/rtfx/files/patch-libs-domc-Makefile b/textproc/rtfx/files/patch-libs-domc-Makefile
new file mode 100644
index 000000000000..44a7c55db053
--- /dev/null
+++ b/textproc/rtfx/files/patch-libs-domc-Makefile
@@ -0,0 +1,8 @@
+--- libs/domc/Makefile.orig Tue Oct 17 01:25:18 2006
++++ libs/domc/Makefile Sun Nov 5 23:37:10 2006
+@@ -1,4 +1,4 @@
+-_EXTRA = -I../libmba/src/ -L../libmba/
++_EXTRA = -I${LOCALBASE}/include/ -L${LOCALBASE}/lib/
+ prefix = ./
+ includedir = $(prefix)
+ libdir = $(prefix)
diff --git a/textproc/rtfx/pkg-plist b/textproc/rtfx/pkg-plist
deleted file mode 100644
index d7fd1e655e9d..000000000000
--- a/textproc/rtfx/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/rtfx