aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-escape
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-03-29 21:00:05 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-03-29 21:00:05 +0000
commit7820ddae48bc4975264ee6f9a039e2343a435b35 (patch)
treed82402535f341972b0ccb1380555126410fe28e4 /textproc/ruby-escape
parent5f7fe87ed73801b0c470a7c070a2272c60480999 (diff)
downloadports-7820ddae48bc4975264ee6f9a039e2343a435b35.tar.gz
ports-7820ddae48bc4975264ee6f9a039e2343a435b35.zip
Notes
Diffstat (limited to 'textproc/ruby-escape')
-rw-r--r--textproc/ruby-escape/Makefile33
-rw-r--r--textproc/ruby-escape/distinfo2
-rw-r--r--textproc/ruby-escape/pkg-descr12
-rw-r--r--textproc/ruby-escape/pkg-plist4
4 files changed, 51 insertions, 0 deletions
diff --git a/textproc/ruby-escape/Makefile b/textproc/ruby-escape/Makefile
new file mode 100644
index 000000000000..559fb03ca09f
--- /dev/null
+++ b/textproc/ruby-escape/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ruby-escape
+# Date created: 2011-03-29
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= escape
+PORTVERSION= 0.2
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.a-k-r.org/${PORTNAME}/ \
+ ${MASTER_SITE_LOCAL:S|%SUBDIR%|tota/ruby-escape|}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ${RUBY_PKGNAMEPREFIX:S|${RUBY_SUFFIX}-||}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= A Ruby library provies HTML/URI/shell escaping functions
+
+USE_RUBY= yes
+NO_BUILD= yes
+
+DOCS= ChangeLog README
+
+do-install:
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/escape.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-escape/distinfo b/textproc/ruby-escape/distinfo
new file mode 100644
index 000000000000..e84780b0e5f0
--- /dev/null
+++ b/textproc/ruby-escape/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ruby/escape-0.2.tar.gz) = d121f9424e9cbd5f59a85d8d7a839c3f84839af0d946c7de9386bd5af324ad54
+SIZE (ruby/escape-0.2.tar.gz) = 19317
diff --git a/textproc/ruby-escape/pkg-descr b/textproc/ruby-escape/pkg-descr
new file mode 100644
index 000000000000..f574c333c7a5
--- /dev/null
+++ b/textproc/ruby-escape/pkg-descr
@@ -0,0 +1,12 @@
+Ruby escape - HTML/URI/shell escaping utilities
+
+Features:
+ - several escaping/composing functions
+ * HTML text
+ * HTML attribute value
+ * URI path
+ * shell command line
+ - dedicated classes for escaped strings
+ - escape and compose strongly related strings at once
+
+WWW: http://www.a-k-r.org/escape/
diff --git a/textproc/ruby-escape/pkg-plist b/textproc/ruby-escape/pkg-plist
new file mode 100644
index 000000000000..160e8447c239
--- /dev/null
+++ b/textproc/ruby-escape/pkg-plist
@@ -0,0 +1,4 @@
+%%RUBY_SITELIBDIR%%/escape.rb
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%