aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-rss.alt/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-03-23 08:45:41 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-03-23 08:45:41 +0000
commitbe6f5be48f45025fa39aa6846274882fe2605401 (patch)
treeeaa3ab1ec82c11ffbb4a2c145b7d07d27d5f9a22 /textproc/ruby-rss.alt/Makefile
parent151f0e49d43966f9472d8186589bc7b096d65810 (diff)
downloadports-be6f5be48f45025fa39aa6846274882fe2605401.tar.gz
ports-be6f5be48f45025fa39aa6846274882fe2605401.zip
Notes
Diffstat (limited to 'textproc/ruby-rss.alt/Makefile')
-rw-r--r--textproc/ruby-rss.alt/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/textproc/ruby-rss.alt/Makefile b/textproc/ruby-rss.alt/Makefile
new file mode 100644
index 000000000000..973262121056
--- /dev/null
+++ b/textproc/ruby-rss.alt/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby/RSS (alternative impl.)
+# Date created: 23 March 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rss
+PORTVERSION= 0.0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= http://cozmixng.sgk.iwate-u.ac.jp/~kou/download/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+PKGNAMESUFFIX= .alt
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Ruby library for handling RSS (alternative impl.)
+
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/uconv.so:${PORTSDIR}/japanese/ruby-uconv \
+ ${RUBY_SITELIBDIR}/xmlscan/parser.rb:${PORTSDIR}/textproc/ruby-xmlscan
+# You can use REXML as an alternative to xmlscan, but 2.5.0 or later only:
+# ${RUBY_SITELIBDIR}/rexml/document.rb:${PORTSDIR}/textproc/ruby-rexml
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+DOCS_EN= README.en Tutorial.en
+DOCS_JA= README.ja Tutorial.ja
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>