aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-amatch
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2014-09-21 15:13:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2014-09-21 15:13:07 +0000
commit4b310fd5a0eb868024564e76840a74bc701ddab6 (patch)
tree9add6580f7501287bf60cbb2f4ff6ac79a5259ca /textproc/rubygem-amatch
parent5c5de92aa5667647b2b775f8109e5fcea9ab78df (diff)
downloadports-4b310fd5a0eb868024564e76840a74bc701ddab6.tar.gz
ports-4b310fd5a0eb868024564e76840a74bc701ddab6.zip
This is a Ruby library for approximate string matching and searching
using a dynamic programming algorithm to compute the Levenstein distance between strings. Written in C for speed. WWW: http://flori.github.io/amatch/
Notes
Notes: svn path=/head/; revision=368767
Diffstat (limited to 'textproc/rubygem-amatch')
-rw-r--r--textproc/rubygem-amatch/Makefile15
-rw-r--r--textproc/rubygem-amatch/distinfo2
-rw-r--r--textproc/rubygem-amatch/pkg-descr5
3 files changed, 22 insertions, 0 deletions
diff --git a/textproc/rubygem-amatch/Makefile b/textproc/rubygem-amatch/Makefile
new file mode 100644
index 000000000000..23752399110a
--- /dev/null
+++ b/textproc/rubygem-amatch/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= amatch
+PORTVERSION= 0.3.0
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby library for approximate string matching and searching
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-amatch/distinfo b/textproc/rubygem-amatch/distinfo
new file mode 100644
index 000000000000..135c7b3e4c2a
--- /dev/null
+++ b/textproc/rubygem-amatch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/amatch-0.3.0.gem) = 669bac06769ab21d2fbd87839b5aa1b1d9e0eb39971b4404fe88de103685f45d
+SIZE (rubygem/amatch-0.3.0.gem) = 28672
diff --git a/textproc/rubygem-amatch/pkg-descr b/textproc/rubygem-amatch/pkg-descr
new file mode 100644
index 000000000000..3717b7647256
--- /dev/null
+++ b/textproc/rubygem-amatch/pkg-descr
@@ -0,0 +1,5 @@
+This is a Ruby library for approximate string matching and searching
+using a dynamic programming algorithm to compute the Levenstein
+distance between strings. Written in C for speed.
+
+WWW: http://flori.github.io/amatch/